You are not logged in.

#1 2011-11-16 06:41:05

hadian
Member
Registered: 2011-09-09
Posts: 7

pptp vpn connection

i installed Archbang 2011-11 on a pc. i need a pptp vpn connection to connect to Internet but the required packages are not installed. How can i install these packages offline? i mean, is there any way that i download the required packages from another OS and install them on Archbang? if yes, which packages should i install to be able to create a pptp connection by network-manager applet?

Offline

#2 2011-11-16 08:49:49

ArchVortex
Retired
From: Ts’elxweyeqw, Canada
Registered: 2011-04-01
Posts: 1,465

Re: pptp vpn connection

You can see the VPN plugins you need for networkmanager here http://www.archlinux.org/packages/?sort … =&limit=50 and you can download the .pkg.tar.xz from http://arm.konnichi.com/2011/11/15/extra/os/  on to a usb stick and move them to Downloads or whatever folder you like. Then as root:

pacman -U /home/yourusername/Downloads/nameofthepackage.pkg.tar.xz  

to install the package without the internet. I have to do the same thing to get my 3G modem to work.


You have the capacity to learn from mistakes. You'll learn a lot today.
FP:E5F8 7DBA 8128 9ACB 75F7 7279 BE34 AB66 76D9 16DE
KEY ID:76D916DE
Currently running ArchBang / LFS / OpenSUSE Tumbleweed

Offline

#3 2011-11-16 11:55:34

Kruppt
Moderator
From: Blue Ridge Mountains, NC
Registered: 2010-12-20
Posts: 299

Re: pptp vpn connection

hadian wrote:

i installed Archbang 2011-11 on a pc. i need a pptp vpn connection to connect to Internet but the required packages are not installed. How can i install these packages offline? i mean, is there any way that i download the required packages from another OS and install them on Archbang? if yes, which packages should i install to be able to create a pptp connection by network-manager applet?

Yes..if you can find a Linux LiveCD that has the packages needed to make a network connection,
you can boot into this particular LiveCd environment, and chroot into the ArchBang Partition and use pacman or packer
to install the packages needed. If another Linux distribution is installed on same machine and your
network is configured in this particular distro, you could also chroot from this distro into the ArchBang root partition.

Once you are booted into this LiveCd or installed Linux OS environment and have established your network connection
you would do like follows.

Open a terminal and enter root user via "sudo /bin/bash", "su root" "sudo -i" or whichever method you are familiar with and do
as follows:

Run "fdisk -l" in this root term to determine which device the Archbang root partition actually is.

Make the mount point if it does not already exist via "mkdir /mnt/sdxx".
After mount point has been created
Mount this partition like so. "mount /dev/sdxx /mnt/sdxx".

Just an example:
mkdir /mnt/sda5
mount /dev/sda5 /mnt/sda5
that is, if the ArchBang root partition WAS /dev/sda5 as determined via output of fdisk -l shown earlier in post.

After ArchBang partition is mounted, copy resolv.conf to /etc of ArchBang partition via same root term:
"cp -vf /etc/resolv.conf /mnt/sdxx/etc"


mount -t proc proc ${new_arch}/proc
mount -t sysfs sys ${new_arch}/sys
mount -o bind /dev ${new_arch}/dev

**note that ${new_arch} would be your actual archbang installation's mount point,
using /dev/sda5 mounted as /mnt/sda5 as an EXAMPLE the commands above would look like so:

mount -t proc proc /mnt/sda5/proc
mount -t sysfs sys /mnt/sda5/sys
mount -o bind /dev /mnt/sda5/dev

Now chroot into the ArchBang partition.
"chroot /mnt/sdxx"

Run "pacman -Sy" and after repos are updated
run "pacman -S packagename_1 packagename_2 packagename_3 packname_etc"
to install all packages needed.
After packages have been installed, type "exit" to exit chroot.

Note that sdxx would be the actual partition device as found via fdisk -l,
and the commands are inside double quotes, do not use the double quotes on command line.

Edit: Take note of below packages...it appears you would do "pacman -S pptpclient networkmanager-pptp pptpd"
to install packages need.

[root@MS-7005-archbang ~]# packer -Ss pptp
core/pptpclient 1.7.2-3 [0.03 MB]
    Client for the proprietary Microsoft Point-to-Point Tunneling Protocol, PPTP.
extra/networkmanager-pptp 0.9.2.0-1 [0.08 MB]
    NetworkManager VPN plugin for pptp
community/pptpd 1.3.4-4 [0.03 MB]
    Poptop server

https://wiki.archlinux.org/index.php/PPTP_Server

Last edited by Kruppt (2011-11-16 21:42:42)

Offline

#4 2011-11-16 13:35:27

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,626
Website

Re: pptp vpn connection

Very clear explanation howto chroot; something for the wiki?


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#5 2011-11-16 14:03:40

oliver
Administrator
Registered: 2010-11-04
Posts: 2,209

Re: pptp vpn connection

one thing worth remembering with chroot is that if you have a 64 bit installation, you have to use a 64 bit live CD too.

Offline

#6 2011-11-16 23:52:24

ArchVortex
Retired
From: Ts’elxweyeqw, Canada
Registered: 2011-04-01
Posts: 1,465

Re: pptp vpn connection

How to chroot with a live CD added to Wiki with special thanks to Kruppt!!


You have the capacity to learn from mistakes. You'll learn a lot today.
FP:E5F8 7DBA 8128 9ACB 75F7 7279 BE34 AB66 76D9 16DE
KEY ID:76D916DE
Currently running ArchBang / LFS / OpenSUSE Tumbleweed

Offline

#7 2011-11-17 03:48:42

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,626
Website

Re: pptp vpn connection

Thanks, AVOL, would you add this valuable and important addition of Oliver:

one thing worth remembering with chroot is that if you have a 64 bit installation, you have to use a 64 bit live CD too.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#8 2011-11-17 03:59:00

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,880

Re: pptp vpn connection

mount - t proc proc proc/

Stops archbey complaining smile


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org Artix information https://artix-linux.github.io/migrate/

Offline

#9 2011-11-17 05:03:22

ArchVortex
Retired
From: Ts’elxweyeqw, Canada
Registered: 2011-04-01
Posts: 1,465

Re: pptp vpn connection

Done again!


You have the capacity to learn from mistakes. You'll learn a lot today.
FP:E5F8 7DBA 8128 9ACB 75F7 7279 BE34 AB66 76D9 16DE
KEY ID:76D916DE
Currently running ArchBang / LFS / OpenSUSE Tumbleweed

Offline

#10 2011-11-19 07:56:38

hadian
Member
Registered: 2011-09-09
Posts: 7

Re: pptp vpn connection

thanks,
i instralled the packages by chroot to Archbang from Debian ( and mounting /proc).
(i could connect to internet by Archbang and installed gnome. now i am installing nvidia driver..... big_smile)

Offline

#11 2011-11-19 08:41:00

ArchVortex
Retired
From: Ts’elxweyeqw, Canada
Registered: 2011-04-01
Posts: 1,465

Re: pptp vpn connection

@hadian

Thanks for reporting back that it worked for you!!


You have the capacity to learn from mistakes. You'll learn a lot today.
FP:E5F8 7DBA 8128 9ACB 75F7 7279 BE34 AB66 76D9 16DE
KEY ID:76D916DE
Currently running ArchBang / LFS / OpenSUSE Tumbleweed

Offline

#12 2011-11-19 20:58:31

hadian
Member
Registered: 2011-09-09
Posts: 7

Re: pptp vpn connection

problem again!!!!
after installing the above packages i boot the system with Archbang and created the connection and it was working. after installing the gnome and rebooting the system, the connection does not work. here is what i did:
1- install gnome, gnome-extra and gdm
2- editing ~/.xinitrc file to launch gnome-session
3- logging out and login - gnome was not started correctly because of missing nvidia driver and entered fall-back mode. but the connections was ok and working.
4- install nvidia driver
5- reboot the system. gnome is ok but the connections does not work. when i click to turn on the connection, it blinks only!!!!

Last edited by hadian (2011-11-19 21:05:47)

Offline

#13 2011-11-20 15:21:06

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,626
Website

Re: pptp vpn connection

I can't see that/how installing a video driver affects your connection.
Didn't you upgrade other packages?
Try to find out via pacman.log in / var/log/and downgrade possible suspects.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#14 2011-11-21 06:03:44

hadian
Member
Registered: 2011-09-09
Posts: 7

Re: pptp vpn connection

i niticed that the problem is in gnome only. when i login to openbox, the connections work well (i am working in openbox now) but there is a problem in Gnome. any comment?

Offline

#15 2011-11-21 14:34:06

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,626
Website

Re: pptp vpn connection

In the gnome environment another application may be responsible for the pptp connection and settings might in how it is integrated in the DE may be different.
Check this out in a more gnome oriented forum like Mint or Ubuntu.
AB is an Openbox distro.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

Board footer

Powered by FluxBB