You are not logged in.

#1 2017-09-28 15:11:00

LizziAS
Member
Registered: 2017-09-24
Posts: 30

bluetooth isn't working...

i have installed all the bluetooth files for gtk/gnome to get bluetooth working and i have two wifi/bt4.0 modules for my brixand i ahve tried both... neither works in archbang presently.  i had trouble before that one of them wasn't working in manjaro and the other was.  both work in windows so i know the devices arent borked..



sudo rc-service bluetooth start
* rc-service: service `bluetooth' does not exist
sudo rc-update add bluetooth default
* rc-update: service `bluetooth' does not exist


fkill list bluetooth
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no


inxi -Fxzc0
System:    Host: archbang-openrc Kernel: 4.9.44-1-lts x86_64 (64 bit gcc: 7.1.1) Desktop: Openbox 3.6.1
           Distro: ArchBang-OpenRC Linux
Machine:   Device: laptop Mobo: GIGABYTE model: M1M3XCP-00 v: 1.x UEFI: American Megatrends v: F3 date: 10/30/2015
CPU:       Quad core AMD A8-5557M APU with Radeon HD Graphics (-MCP-) cache: 8192 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm) bmips: 16768
           clock speeds: max: 2100 MHz 1: 1400 MHz 2: 1400 MHz 3: 1400 MHz 4: 1400 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Richland [Radeon HD 8550G] bus-ID: 00:01.0
           Display Server: X.Org 1.19.3 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1280x1024@60.02hz
           OpenGL: renderer: AMD ARUBA (DRM 2.49.0 / 4.9.44-1-lts, LLVM 5.0.0)
           version: 4.1 Mesa 17.2.1 Direct Render: Yes
Audio:     Card-1 Advanced Micro Devices [AMD] FCH Azalia Controller driver: snd_hda_intel bus-ID: 00:14.2
           Card-2 Advanced Micro Devices [AMD/ATI] Trinity HDMI Audio Controller
           driver: snd_hda_intel bus-ID: 00:01.1
           Sound: Advanced Linux Sound Architecture v: k4.9.44-1-lts
Network:   Card-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8169 v: 2.3LK-NAPI port: e000 bus-ID: 05:00.0
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter
           driver: rtl8821ae port: d000 bus-ID: 06:00.0
           IF: wlp6s0 state: down mac: <filter>
Drives:    HDD Total Size: 752.4GB (3.1% used)
           ID-1: /dev/sda model: MT size: 128.0GB temp: 33C
           ID-2: /dev/sdb model: TOSHIBA_MK5075GS size: 500.1GB temp: 33C
           ID-3: USB /dev/sdc model: Ultra_Fit size: 124.2GB temp: 0C
Partition: ID-1: / size: 25G used: 4.6G (20%) fs: btrfs dev: /dev/sdc2
           ID-2: /var/tmp size: 15G used: 1.1G (8%) fs: ext4 dev: /dev/sdb7
           ID-3: /home size: 90G used: 993M (2%) fs: btrfs dev: /dev/sdc3
           ID-4: swap-1 size: 17.18GB used: 0.00GB (0%) fs: swap dev: /dev/sdb5
Sensors:   System Temperatures: cpu: 50.4C mobo: N/A gpu: 50.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 189 Uptime: 20 min Memory: 1143.7/11207.5MB
           Init: N/A rc: OpenRC runlevel: default Gcc sys: 7.2.0 Client: Shell (bash 4.4.121) inxi: 2.3.23



and just for good measure:
sudo rfkill unblock bluetooth


and finally:

/usr/lib/bluetooth/bluetoothd
D-Bus setup failed: Connection ":1.24" is not allowed to own the service "org.bluez" due to security policies in the configuration file



[General]

# Default adapter name
# Defaults to 'BlueZ X.YZ'
#Name = BlueZ

# Default device class. Only the major and minor device class bits are
# considered. Defaults to '0x000000'.
#Class = 0x000100

# How long to stay in discoverable mode before going back to non-discoverable
# The value is in seconds. Default is 180, i.e. 3 minutes.
# 0 = disable timer, i.e. stay discoverable forever
#DiscoverableTimeout = 0

# How long to stay in pairable mode before going back to non-discoverable
# The value is in seconds. Default is 0.
# 0 = disable timer, i.e. stay pairable forever
#PairableTimeout = 0

# Automatic connection for bonded devices driven by platform/user events.
# If a platform plugin uses this mechanism, automatic connections will be
# enabled during the interval defined below. Initially, this feature
# intends to be used to establish connections to ATT channels. Default is 60.
#AutoConnectTimeout = 60

# Use vendor id source (assigner), vendor, product and version information for
# DID profile support. The values are separated by ":" and assigner, VID, PID
# and version.
# Possible vendor id source values: bluetooth, usb (defaults to usb)
#DeviceID = bluetooth:1234:5678:abcd

# Do reverse service discovery for previously unknown devices that connect to
# us. This option is really only needed for qualification since the BITE tester
# doesn't like us doing reverse SDP for some test cases (though there could in
# theory be other useful purposes for this too). Defaults to 'true'.
#ReverseServiceDiscovery = true

# Enable name resolving after inquiry. Set it to 'false' if you don't need
# remote devices name and want shorter discovery cycle. Defaults to 'true'.
#NameResolving = true

# Enable runtime persistency of debug link keys. Default is false which
# makes debug link keys valid only for the duration of the connection
# that they were created for.
#DebugKeys = false

# Restricts all controllers to the specified transport. Default value
# is "dual", i.e. both BR/EDR and LE enabled (when supported by the HW).
# Possible values: "dual", "bredr", "le"
ControllerMode = dual

# Enables Multi Profile Specification support. This allows to specify if
# system supports only Multiple Profiles Single Device (MPSD) configuration
# or both Multiple Profiles Single Device (MPSD) and Multiple Profiles Multiple
# Devices (MPMD) configurations.
# Possible values: "off", "single", "multiple"
MultiProfile = multiple

# Permanently enables the Fast Connectable setting for adapters that
# support it. When enabled other devices can connect faster to us,
# however the tradeoff is increased power consumptions. This feature
# will fully work only on kernel version 4.1 and newer. Defaults to
# 'false'.
#FastConnectable = false

# Default privacy setting.
# Enables use of private address.
# Possible values: "off", "device", "network"
# "network" option not supported currently
# Defaults to "off"
# Privacy = off

[GATT]
# GATT attribute cache.
# Possible values:
# always: Always cache attributes even for devices not paired, this is
# recommended as it is best for interoperability, with more consistent
# reconnection times and enables proper tracking of notifications for all
# devices.
# yes: Only cache attributes of paired devices.
# no: Never cache attributes
# Default: always
Cache = always

[Policy]
#
# The ReconnectUUIDs defines the set of remote services that should try
# to be reconnected to in case of a link loss (link supervision
# timeout). The policy plugin should contain a sane set of values by
# default, but this list can be overridden here. By setting the list to
# empty the reconnection feature gets disabled.
#ReconnectUUIDs=00001112-0000-1000-8000-00805f9b34fb,0000111f-0000-1000-8000-00805f9b34fb,0000110a-0000-1000-8000-00805f9b34fb

# ReconnectAttempts define the number of attempts to reconnect after a link
# lost. Setting the value to 0 disables reconnecting feature.
#ReconnectAttempts=7

# ReconnectIntervals define the set of intervals in seconds to use in between
# attempts.
# If the number of attempts defined in ReconnectAttempts is bigger than the
# set of intervals the last interval is repeated until the last attempt.
#ReconnectIntervals=1,2,4,8,16,32,64

# AutoEnable defines option to enable all controllers when they are found.
# This includes adapters present on start as well as adapters that are plugged
# in later on. Defaults to 'false'.
AutoEnable=true



bluetoothctl
Waiting to connect to bluetoothd...

Last edited by LizziAS (2017-09-28 15:18:19)

Offline

#2 2017-09-28 18:58:11

eric
Member
Registered: 2015-07-10
Posts: 239
Website

Re: bluetooth isn't working...

/usr/lib/bluetooth/bluetoothd is expect to be run with root privilegies...


Obarun : free to control your system

Offline

#3 2017-09-29 10:14:30

LizziAS
Member
Registered: 2017-09-24
Posts: 30

Re: bluetooth isn't working...

eric wrote:

/usr/lib/bluetooth/bluetoothd is expect to be run with root privilegies...


Seems risky

Offline

#4 2017-09-30 09:07:54

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,913

Re: bluetooth isn't working...

I do have Bluetooth working on my laptop, away at the moment can check how I got it working on my return.


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org Artix information https://artixlinux.org/migrate.php

Offline

#5 2017-10-01 04:49:24

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,913

Re: bluetooth isn't working...

I used these packages...

blueman
bluez
bluez-libs
bluez-openrc

Start bluetooth service...

Using blueman-applet for tray....


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org Artix information https://artixlinux.org/migrate.php

Offline

#6 2017-10-04 21:36:25

LizziAS
Member
Registered: 2017-09-24
Posts: 30

Re: bluetooth isn't working...

did you run bluetoothd with root privileges?

Offline

#7 2017-10-05 09:01:31

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,913

Re: bluetooth isn't working...

No simply started service....

sudo rc-update add bluetooth default

Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org Artix information https://artixlinux.org/migrate.php

Offline

#8 2017-10-21 22:37:03

LizziAS
Member
Registered: 2017-09-24
Posts: 30

Re: bluetooth isn't working...

Mr Green wrote:

No simply started service....

sudo rc-update add bluetooth default

as my op shows...  i did that and it still didnt work

Offline

#9 2017-10-22 05:45:32

seventh
Member
Registered: 2017-02-07
Posts: 73

Re: bluetooth isn't working...

possibly a group permission problem??

add your user to dbus and sys and see if that helps.

gpasswd -a (your user) dbus

then reboot.

Offline

#10 2017-11-28 17:25:30

LizziAS
Member
Registered: 2017-09-24
Posts: 30

Re: bluetooth isn't working...

seventh wrote:

possibly a group permission problem??

add your user to dbus and sys and see if that helps.

gpasswd -a (your user) dbus

then reboot.



havent tried that yet but i will

i've eliminated the need for bluetooth by purchasing a scepter 32 inch tv on discount that i am using as a monitor and so with the tv having built in speakers, i have no need for bluetooth presently but will test it out once i resolve my update issue with pacman in another thread..

Thank you for your efforts one and all!!!

Offline

Board footer

Powered by FluxBB