You are not logged in.

#1 2017-09-02 09:07:03

Xaver
Member
Registered: 2017-07-26
Posts: 28

Pipemenu does not work anymore after upgrade on Sep.2 2017

The pipemenu creates error message after upgrade.
<menu id="applications" label="Applications" execute="xdg_menu --format openbox3-pipe --root-menu /etc/xdg/menus/arch-applications.menu" />

These packages were upgraded:
libpng-1.6.32-1
libproxy-0.4.15-6
libxml2-2.9.5rc2+0+g69936b12-1
mesa-17.1.8-1
perl-xml-parser-2.44-6

What is the problem? How can we fix it?

Offline

#2 2017-09-03 00:39:30

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,906

Re: Pipemenu does not work anymore after upgrade on Sep.2 2017

Will check out my latest build, see if menu still works....


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org Artix information https://artixlinux.org/migrate.php

Offline

#3 2017-09-03 01:55:06

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,906

Re: Pipemenu does not work anymore after upgrade on Sep.2 2017

Must be a problem with perl/xml, can only suggest a downgrade at the moment. Cannot find any posts on main archlinux forums...


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org Artix information https://artixlinux.org/migrate.php

Offline

#4 2017-09-03 04:22:52

tilt
Member
From: Italy
Registered: 2017-07-16
Posts: 6

Re: Pipemenu does not work anymore after upgrade on Sep.2 2017

Hi @MrGreen,
maybe this could be useful?
https://www.archlinux.org/news/perl-lib … th-change/


Tilt

Offline

#5 2017-09-03 08:28:44

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,906

Re: Pipemenu does not work anymore after upgrade on Sep.2 2017

Possibly but it does state Cpan loaded libraries so not sure... will check just the same

Thanks


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org Artix information https://artixlinux.org/migrate.php

Offline

#6 2017-09-03 12:13:46

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,906

Re: Pipemenu does not work anymore after upgrade on Sep.2 2017

Issue is that [system] perl and perl-xml-parser are not up to date (with archlinux). A temporary fix is to enable [core], disable [system] and update those packages. Remember to reverse them to reduce any more possible issues.

This for me allowed xdg_menu to work again


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org Artix information https://artixlinux.org/migrate.php

Offline

#7 2017-09-04 02:46:39

Xaver
Member
Registered: 2017-07-26
Posts: 28

Re: Pipemenu does not work anymore after upgrade on Sep.2 2017

Another workaround: use openbox-menu
Unfortunately the package from the AUR demands 'strip' as dependency, which I could not find anywhere.
But you can download and install the package 'openbox-menu-0.8.0-1-x86_64.pkg.tar.xz' from the Anergos mirrors:
http://mirrors.antergos.com/antergos/x86_64/

The command for the pipe-menu is:
'openbox-menu arch-applications.menu'  or  'openbox-menu lxde-applications.menu'

Offline

Board footer

Powered by FluxBB