You are not logged in.

#1 2016-09-23 02:59:32

fossiili
Member
From: Oulu, Finland
Registered: 2016-05-15
Posts: 14

Can not uppgrade .... what is wrong ...

This has lasted about a month:

[root@archbang ukki]# pacman -Syu
:: Synchronizing package databases...
core                     120.1 KiB   288K/s 00:00 [######################] 100%
extra                   1756.0 KiB   775K/s 00:02 [######################] 100%
community                  3.6 MiB   846K/s 00:04 [######################] 100%
openrc-eudev is up to date
:: Starting full system upgrade...
:: Replace dbus-openrc with openrc-eudev/dbus-openrc? [Y/n]
:: Replace eudev-systemdcompat with openrc-eudev/eudev-systemd? [Y/n]
:: Replace eudev-systemdcompat with openrc-eudev/libeudev-systemd? [Y/n]
:: Replace libdbus with core/dbus? [Y/n]
resolving dependencies...
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libsystemd", a dependency of "util-linux"
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libsystemd", a dependency of "util-linux"
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libsystemd", a dependency of "dbus"
warning: cannot resolve "dbus", a dependency of "chromium"
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libsystemd", a dependency of "dbus"
warning: cannot resolve "dbus", a dependency of "consolekit"
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libsystemd", a dependency of "dhcpcd"
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libsystemd", a dependency of "dbus"
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libsystemd", a dependency of "util-linux"
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libsystemd", a dependency of "util-linux"
warning: cannot resolve "libeudev", a dependency of "libeudev-systemd"
warning: cannot resolve "libsystemd", a dependency of "util-linux"
:: The following packages cannot be upgraded due to unresolvable dependencies:
      chromium  consolekit  dhcpcd  libeudev-systemd  dbus  util-linux

:: Do you want to skip the above packages for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: libeudev-systemd: requires libeudev
:: util-linux: requires libsystemd
:: libeudev-systemd: requires libeudev
:: util-linux: requires libsystemd
:: libeudev-systemd: requires libeudev
:: dbus: requires libsystemd
:: chromium: requires dbus
:: libeudev-systemd: requires libeudev
:: dbus: requires libsystemd
:: consolekit: requires dbus
:: libeudev-systemd: requires libeudev
:: dhcpcd: requires libsystemd
:: libeudev-systemd: requires libeudev
:: libeudev-systemd: requires libeudev
:: dbus: requires libsystemd
:: libeudev-systemd: requires libeudev
:: util-linux: requires libsystemd
:: libeudev-systemd: requires libeudev
:: util-linux: requires libsystemd
:: libeudev-systemd: requires libeudev
:: util-linux: requires libsystemd
[root@archbang ukki]#

:rolleyes

Offline

#2 2016-09-23 10:44:22

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,728

Re: Can not uppgrade .... what is wrong ...

The issue is the last dbus-update in arch. You need to run a few more commands to get back up and running.

http://bbs.archbang.org/viewtopic.php?id=5740

Might help


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#3 2016-09-24 06:17:43

fossiili
Member
From: Oulu, Finland
Registered: 2016-05-15
Posts: 14

Re: Can not uppgrade .... what is wrong ...

Sorry but I do not understand what I shall do sad
Shall I answer in a certain way to the Yes/No-questions presented while the full system uppgrade?
Or shall I remove some d-bus directory or file and somehow get an older and working version of it?

Or simply waite that:

This issue (along with dbus update) should be solved in next release.

Recently I am in my summer cottage in an iland on the Gulf of Finland but soon I'll drive back to home in Northern Finland. But I will come back on December and try the system uppgrade then. What about that?

Offline

#4 2016-09-24 13:12:02

Chris Cromer
Member
Registered: 2016-06-12
Posts: 25

Re: Can not uppgrade .... what is wrong ...

Looks like the problem is in the openrc-eudev repo, not in arch-openrc/arch-nosystemd. I will point archnous here to let him take a look.

Offline

#5 2016-09-24 14:04:59

nous
Member
From: Across the Universe
Registered: 2015-05-03
Posts: 4
Website

Re: Can not uppgrade .... what is wrong ...

fossiili wrote:

Sorry but I do not understand what I shall do sad
Shall I answer in a certain way to the Yes/No-questions presented while the full system uppgrade?
Or shall I remove some d-bus directory or file and somehow get an older and working version of it?

Or simply waite that:

This issue (along with dbus update) should be solved in next release.

Recently I am in my summer cottage in an iland on the Gulf of Finland but soon I'll drive back to home in Northern Finland. But I will come back on December and try the system uppgrade then. What about that?

You should read the systemd-free news page whenever you encounter issues (this holds true for upstream Arch Linux too). Anyway, taking in account all the recent changes, you have to issue these commands:

pacman -Sydd eudev eudev-systemd libeudev libeudev-systemd dbus-openrc dbus-nosystemd

Answer yes to all questions. Then, proceed with pacman -Su and profit. Bring us back some snow from Northern Finland!

[EDIT] To avoid duplicate work and other inconsistencies, the [openrc-eudev] repo will soon be replaced by [arch-openrc] and [arch-nosystemd], but I need to have some free time to test the transition before making it final.

Last edited by nous (2016-09-24 14:13:48)

Offline

#6 2016-09-25 00:29:04

fossiili
Member
From: Oulu, Finland
Registered: 2016-05-15
Posts: 14

Re: Can not uppgrade .... what is wrong ...

pacman -Sydd eudev eudev-systemd libeudev libeudev-systemd dbus-openrc dbus-nosystemd

[root@archbang ukki]# pacman -Sydd eudev eudev-systemd libeudev libeudev-systemd dbus-openrc dbus-nosystemd
:: Synchronizing package databases...
 core                     120.1 KiB   346K/s 00:00 [######################] 100%
 extra                   1756.1 KiB   806K/s 00:02 [######################] 100%
 community                  3.6 MiB   639K/s 00:06 [######################] 100%
 openrc-eudev              26.9 KiB   245K/s 00:00 [######################] 100%
error: target not found: libeudev
[root@archbang ukki]# 

Here I used the same method (copy/paste) as in the school on 1940-50 - not any great success ....

Bring us back some snow from Northern Finland!

I'll do that when I come back on December!

Offline

#7 2016-09-25 03:02:53

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,728

Re: Can not uppgrade .... what is wrong ...

@fossiii can you post your mirrorlist files? have a feeling you are using the wrong repos... as nous has stated we are now using the arch-openrc arch-nosystemd ones which would make your life so much easier.

@nous Welcome to ArchBang wink


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#8 2016-09-25 03:12:35

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,728

Re: Can not uppgrade .... what is wrong ...

You should have this in pacman.conf

[arch-openrc]
Include = /etc/pacman.d/mirrorlist-openrc

[arch-nosystemd]
Include = /etc/pacman.d/mirrorlist-openrc

mirrorlist-openrc

#
## Arch Linux OpenRC repository mirrorlist
## Generated on 2016-06-09
##

Server = http://downloads.sourceforge.net/project/archopenrc/$repo/$arch
#Server = http://archbang.org/archopenrc/$repo/$arch
Server = ftp://ftp.heanet.ie/mirrors/sourceforge/a/ar/archopenrc/$repo/$arch

Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#9 2016-09-25 09:51:11

nous
Member
From: Across the Universe
Registered: 2015-05-03
Posts: 4
Website

Re: Can not uppgrade .... what is wrong ...

That's really strange; fossiili seems to be using the old [openrc-eudev], not the newer ones, but I'm still maintaining it and as you can see all the packages are there:

titan:[root]:/home/orion# pacman -Syy
>snipped<
titan:[root]:/home/orion# pacman -Sw eudev eudev-systemd libeudev libeudev-systemd dbus-openrc dbus-nosystemd
resolving dependencies...

Package (6)                    Old Version  New Version  Net Change  Download Size

openrc-eudev/dbus-nosystemd    1.10.10-4    1.10.10-4      0.00 MiB       0.25 MiB
openrc-eudev/dbus-openrc       20160917-2   20160923-1     0.00 MiB       0.01 MiB
openrc-eudev/eudev             3.2-4        3.2-4          0.00 MiB       0.86 MiB
openrc-eudev/eudev-systemd     231-7        231-7          0.00 MiB       0.57 MiB
openrc-eudev/libeudev          3.2-4        3.2-4          0.00 MiB       0.07 MiB
openrc-eudev/libeudev-systemd  231-7        231-7          0.00 MiB       0.23 MiB

Total Download Size:  2.00 MiB

:: Proceed with download? [Y/n] 
:: Retrieving packages...
 libeudev-3.2-4-x86_64     71.5 KiB   372K/s 00:00 [##########################]   3%
 eudev-3.2-4-x86_64       956.6 KiB   117K/s 00:08 [##########################]  46%
 eudev-systemd-231-7...  1537.0 KiB   157K/s 00:10 [##########################]  75%
 libeudev-systemd-23...  1773.2 KiB   156K/s 00:11 [##########################]  86%
 dbus-nosystemd-1.10...  2029.5 KiB   160K/s 00:13 [##########################]  99%
 dbus-openrc-2016092...  2043.8 KiB   156K/s 00:13 [##########################] 100%
(6/6) checking keys in keyring                     [##########################] 100%
(6/6) checking package integrity                   [##########################] 100%
titan:[root]:/home/orion# 

Offline

#10 2016-09-25 09:56:36

nous
Member
From: Across the Universe
Registered: 2015-05-03
Posts: 4
Website

Re: Can not uppgrade .... what is wrong ...

Ahhh, you're using the i686 openrc-eudev! That one is kind of neglected, no wonder you had the problem for so long, but I put the missing packages there (courtesy of Chris smile ). Pacman -Syy and retry, sorry for any inconvenience. You should have ranted in the systemd-free.org's comments section.

Cheers, Mr Green!

Last edited by nous (2016-09-25 10:01:09)

Offline

#11 2016-09-25 09:56:53

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,728

Re: Can not uppgrade .... what is wrong ...

Maybe he needs to run -Syyu? or check versions of required packages just to be sure


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#12 2016-09-25 10:06:38

nous
Member
From: Across the Universe
Registered: 2015-05-03
Posts: 4
Website

Re: Can not uppgrade .... what is wrong ...

Mr Green wrote:

Maybe he needs to run -Syyu? or check versions of required packages just to be sure

You're too fast!

Offline

#13 2016-09-25 10:13:26

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,728

Re: Can not uppgrade .... what is wrong ...

We are just grateful for all the hard work you and Chris do wink


Comments, suggestions, donations please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#14 2016-10-11 06:39:04

fossiili
Member
From: Oulu, Finland
Registered: 2016-05-15
Posts: 14

Re: Can not uppgrade .... what is wrong ...

Mr Green wrote:

@fossiii can you post your mirrorlist files? have a feeling you are using the wrong repos... as nous has stated we are now using the arch-openrc arch-nosystemd ones .....

Here is what I found in my ArchBang:

[root@archbang pacman.d]# cat mirrorlist
##
## Arch Linux repository mirrorlist
## Generated on 2016-04-22
##

## Worldwide
Server = http://mirror.rackspace.com/archlinux/$repo/os/$arch

## Australia
#Server = https://mirror.aarnet.edu.au/pub/archlinux/$repo/os/$arch
#Server = http://archlinux.mirror.digitalpacific.com.au/$repo/os/$arch
#Server = http://ftp.iinet.net.au/pub/archlinux/$repo/os/$arch
.......
......
## Finland
Server = http://arch.mirror.far.fi/$repo/os/$arch

How should I change my mirrolist?

Offline

#15 2016-10-11 15:56:33

Chris Cromer
Member
Registered: 2016-06-12
Posts: 25

Re: Can not uppgrade .... what is wrong ...

@fossiili

The openrc repos are not in that file. You should run:

cat /etc/pacman.conf

When arch-openrc is in use there is a new mirrorlist file, it is called /etc/pacman.d/mirrorlist-openrc
If this file does not exist, you are using the openrc-eudev repos instead of the arch-openrc repos.

Offline

#16 2016-10-12 06:05:58

fossiili
Member
From: Oulu, Finland
Registered: 2016-05-15
Posts: 14

Re: Can not uppgrade .... what is wrong ...

Chris Cromer wrote:

@fossiili

The openrc repos are not in that file. You should run:

cat /etc/pacman.conf

When arch-openrc is in use there is a new mirrorlist file, it is called /etc/pacman.d/mirrorlist-openrc
If this file does not exist, you are using the openrc-eudev repos instead of the arch-openrc repos.

Thank you for your answer. I have used some Linux distributions based on Arch, but I have not studied Pacman carefully. I will do that later because I have the hope to someday install The Arch itself!

At the moment - tomorrow I'll start my journey to North but I will come back here on December and start this PC then again.

By writing "cat /etc/pacman.conf" I found this lines

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

I suppose I should change mirrorlist to mirrorlist-openrc. But in my recent ArchBang:

[root@archbang pacman.d]# ls
gnupg  mirrorlist  mirrorlist.pacnew

How can I get mirrorlist-openrc to /etc/pacman.d?  Or did I understand anything about these procedures ...

Offline

#17 2016-10-12 12:42:36

eric
Member
Registered: 2015-07-10
Posts: 231
Website

Re: Can not uppgrade .... what is wrong ...

I'm not using Archbang openrc version, but i think you need to do something like this (certainly some user like Mrgreen, chris can correct this following lines if a error exist) :

First edit and append your /etc/pacman.conf by adding the repository openrc:

[community]
Include = /etc/pacman.d/mirrorlist

[openrc-eudev]
SigLevel=PackageOptional
Server=http://downloads.sourceforge.net/project/archopenrc/$repo/$arch

if you want to use mirrorlist-openrc you need :
create the file at /etc/pacman.d/mirrorlist-openrc
then edit it by adding :

Server=http://downloads.sourceforge.net/project/archopenrc/$repo/$arch

then change your /etc/pacman.conf like this :

[openrc-eudev]
SigLevel=PackageOptional
Server=mirrorlist-openrc

hope it help


Obarun : free to control your system

Offline

#18 2016-10-13 10:54:28

Chris Cromer
Member
Registered: 2016-06-12
Posts: 25

Re: Can not uppgrade .... what is wrong ...

Sorry that information is incorrect. This is what should be in pacman.conf:

[arch-openrc]
Include = /etc/pacman.d/mirrorlist-openrc

[arch-nosystemd]
Include = /etc/pacman.d/mirrorlist-openrc

He also needs to install 2 packages from the repo: openrc-mirrorlist and openrc-keyring

He should NOT be using [openrc-eudev] repos, they are going to be deprecated and replace with the 2 that I listed above.

Most likely you will have a problem since you won't have the openrc keyring yet. My suggestion is to temporarily use this in pacman.conf:

[arch-openrc]
SigLevel = Never
Server=http://downloads.sourceforge.net/project/archopenrc/$repo/$arch

[arch-nosystemd]
SigLevel = Never
Server=http://downloads.sourceforge.net/project/archopenrc/$repo/$arch

This will disable signature checks and not use a mirror file.

Now run pacman -Syy openrc-mirrorlist openrc-keyring

After the keyring is installed change pacman.conf back to this:

[arch-openrc]
Include = /etc/pacman.d/mirrorlist-openrc

[arch-nosystemd]
Include = /etc/pacman.d/mirrorlist-openrc

After that a standard pacman -Syu should upgrade all the openrc packages correctly.

Last edited by Chris Cromer (2016-10-13 10:56:52)

Offline

#19 2016-10-28 05:12:29

fossiili
Member
From: Oulu, Finland
Registered: 2016-05-15
Posts: 14

Re: Can not uppgrade .... what is wrong ...

Hi! I did not start my journey, becouse a frend is in problems with Windows 7 and I promised to give her this computer. But ArchBang may be a bit too difficult for a linux-novice. So I must first to install for ex. Mint Mate or Ubuntu. Just to be certain she will do well with the linux.

But I like ArchBang very much and I'll install it in an other computer later and then start to get a better understanding of Pacman.

Thank You and see you smile

Offline

Board footer

Powered by FluxBB