You are not logged in.

#1 2016-09-07 07:24:32

Silure
Member
Registered: 2016-04-30
Posts: 14

Solved. Heavy download since upgrade??

Hi All
Hope I am posting in the correct place for this problem, (confused by problem.)
This may be completely wrong but since last update (now on Linux 4.7.2-1Arch) I am using huge amounts of data.
I only use a Three mobile MIFI for my Internet as I rarely use the internet at home, at the moment it only gets used to learn about Archbang.
It seems that since last update  I now download many Mb just reading Arch-Wiki pages, (last session 220M) which seems quite a lot!!!
I have UFW installed, plus Clamav. A full clamscan shows no viruses, but I am wondering if my pc could be being used as a robot sending out spam?
I have also noticed that multiple kworker items are appearing in Conky which never was the case before. Also my cooling fan is working overtime even though cpu percentage is very low, typically a few percent.
Hope you can offer some advice.

Silure.

P.S Sorry for this rambling account of my problem.

Last edited by Silure (2016-09-10 07:57:42)

Offline

#2 2016-09-07 07:51:33

oliver
Administrator
Registered: 2010-11-04
Posts: 2,209

Re: Solved. Heavy download since upgrade??

For the CPU issue, use 'top' to see what is running and taking up cycles

For the 'robot' stuff, use 'sudo netstat -a|grep -i est' to see what connections are established

You could also run wireshark and see what is happening over the network

Offline

#3 2016-09-07 13:25:35

TiPo
Member
Registered: 2015-02-08
Posts: 44

Re: Solved. Heavy download since upgrade??

Silure, enlighten me, your problem is:
"It seems that since last update  I now download many Mb just reading Arch-Wiki pages"
??? so jou are causing the huge download by searching a problem you invoke your self?
So what is the real problem? High CPU load?
Multiple kworker items are "normal" but they should not use high CPU and don't need any (directly) download.
And if you experience heavy download, why are you wondering your PC could be used as a robot sending out spam? Is there heavy upload?

Offline

#4 2016-09-10 07:54:37

Silure
Member
Registered: 2016-04-30
Posts: 14

Re: Solved. Heavy download since upgrade??

Hi Oliver
Back at my Computer, sorry for the delay.
I had never used the AUR before and that took a while to master.
I have now tracked my usage with vnstat and have found a large Download, but only a very small Upload, so I no longer worry about spamming. I have now swapped my MIFI for a plug-in Dongle, and I think the problem has gone away, think it is a problem with the MIFI, (Don't understand what it was downloading but hey)

Thanks again for the prompt reply. (You Guys are good)
Silure

Hi TIPo
What I was trying to say and failed was that at the moment all I am doing is Downloading Arch-Wikis to learn about ArchBang which should only amount to a few K of data and what I used was 212 MiB in under 1hr which is far too much.
Anyway as you can read above this problem seems to have gone away with the use of my 3G Dongle.
Thanks for your input.

I will now mark this post as solved

Offline

Board footer

Powered by FluxBB