You are not logged in.

#1 2016-03-16 16:13:14

sinister
Member
Registered: 2016-03-16
Posts: 8

[SOLVED] odd issue with theming

Ok im using a theme i pulled from Manjaro and edited the colors to my liking (Menda-Dark) changing the green highlighting and such to a Arch blue color. Theme works fine all around but apps such as VLC wouldn't theme full dark like the theme. I fixed that by opening prefrences in vlc and selecting GTK3 then back to system default. Now the second part is with Octopi.. When i enable Octopi Notifier and then right click the icon in my systray and select octopi its themed dark matching my theme, but when i open octopi normally through the menu it show up default white/light color theme. I've searched and read through the wiki and cant seem to figure it out. Even looked over the Uniform look for Qt and GTK Applications wiki page and none of that is solving my issue. Like i said when i select Octopi from the right click menu on the octopi systray icon i get a nice dark theme but not when i open it thru the menu.

Last edited by sinister (2016-03-17 18:20:33)

Offline

#2 2016-03-16 16:28:57

sinister
Member
Registered: 2016-03-16
Posts: 8

Re: [SOLVED] odd issue with theming

here are screenshots of what im talking about the first is Octopi opened from either openbox menu or from the xfce4-panel apps menu
Screenshot_2016-03-16_18-22-47.th.png

here is Octopi opened from the right click menu of the Octopi Notifier
Screenshot_2016-03-16_18-23-56-dark.th.png

Offline

#3 2016-03-16 18:56:58

oliver
Administrator
Registered: 2010-11-04
Posts: 2,209

Re: [SOLVED] odd issue with theming

Just a guess because I don't use octopi but I would assume it needs root permissions somehow.  I would assume it's calling sudo but, TBH, I would have said the problem would be the other way around where it looks correct from the menu and not the notifier.

Try running it from the notifier and then issuing a ps and see if you can see exactly how it's called.  Then do the same from the OB menu.

Here's some useful flags for ps so you can see the full output

ps aux | less -+S

edit - what I'm getting at is I suspect one method is not getting your environment settings

Offline

#4 2016-03-16 19:10:36

sinister
Member
Registered: 2016-03-16
Posts: 8

Re: [SOLVED] odd issue with theming

Basically I'm using a dark theme so one would think that when i open it normally from openbox menu, xfce4-panel, or even terminal it would be dark themed but it is not. the only way i can get it to show up dark themed is opening it through the octopi-notifier.

Offline

#5 2016-03-17 00:46:57

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,920

Re: [SOLVED] odd issue with theming

Getting gtk and QT to work theme wise can be difficult. Last time I tried I used qtconfig. Not used octopi would have to read up on what it is to be of any more help.


Comments, suggestions please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#6 2016-03-17 05:10:12

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,633
Website

Re: [SOLVED] odd issue with theming

In your /home/user/.config folder there is a Trolltech.conf file
It opens with

[Qt]
filedialog=@ByteArray( ..

(and then  a few rows of digits and letters.)
Put after these rows at the beginning of a new empty row::

style=GTK+

This will help qt applications to work better together with gtk.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#7 2016-03-17 09:08:17

sinister
Member
Registered: 2016-03-16
Posts: 8

Re: [SOLVED] odd issue with theming

@pablokal I edited the line as you suggested rebooted and nothing. Here is the contents of Trolltech.conf (the section under [QT] )

customColors\0=4294967295
customColors\1=4294967295
customColors\2=4294967295
customColors\3=4294967295
customColors\4=4294967295
customColors\5=4294967295
customColors\6=4294967295
customColors\7=4294967295
customColors\8=4294967295
customColors\9=4294967295
customColors\10=4294967295
customColors\11=4294967295
customColors\12=4294967295
customColors\13=4294967295
customColors\14=4294967295
customColors\15=4294967295
font="Sans Serif,9,-1,5,50,0,0,0,0,0"
Palette\active=#ffffff, #d4d0c8, #ffffff, #e9e7e3, #6a6864, #8d8b85, #ffffff, #ffffff, #ffffff, #000000, #000000, #000000, #000080, #ffffff, #0000ff, #ff00ff, #6a6864, #000000, #ffffdc, #000000
Palette\inactive=#ffffff, #d4d0c8, #ffffff, #f4f0e6, #6a6864, #8d8b85, #ffffff, #ffffff, #ffffff, #000000, #000000, #000000, #000080, #ffffff, #0000ff, #ff00ff, #6a6864, #000000, #ffffdc, #000000
Palette\disabled=#808080, #d4d0c8, #ffffff, #f4f0e6, #6a6864, #8d8b85, #808080, #ffffff, #808080, #000000, #000000, #000000, #000080, #ffffff, #0000ff, #ff00ff, #6a6864, #000000, #ffffdc, #000000
fontPath=@Invalid()
embedFonts=true
style=GTK+
doubleClickInterval=400
cursorFlashTime=1000
wheelScrollLines=3
resolveSymlinks=false
globalStrut\width=0
globalStrut\height=0
useRtlExtensions=false
XIMInputStyle=On The Spot
DefaultInputMethod=xim
audiosink=Auto
videomode=Auto
GUIEffects=none
QT_STYLE_OVERRIDE=GTK+

I'm still leaning towards it being a bug in Octopi itself. When opening Octopi from the notifier in the tray it opens themed dark. And for some reason when its opened normally (from openbox menu) it is not themed dark. I left a comment on AUR for the Octopi devs just now

Offline

#8 2016-03-17 13:45:11

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,633
Website

Re: [SOLVED] odd issue with theming

Ah, you have xfce installed; that takes care of qt rendering with QT_STYLE_OVERRIDE=GTK+ ; so the extra line does nothing.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#9 2016-03-17 14:02:04

sinister
Member
Registered: 2016-03-16
Posts: 8

Re: [SOLVED] odd issue with theming

@pablokal I only have xfce4-panel installed not the whole xfce4 DE . I like it instead of tint2.
i added a comment to the octopi AUR aswell as on github. Like i stated above it's correctly themed when i open it from the notifier in the systray but not when i open it normally from my right click menu or the xfce4-panel. Thats where I'm puzzled and led to believe its a bug in octopi itself... from what im gathering from your comments is that when opened from the octopi-notifier its rendering the proper theme but when opened from the application menu its not.

Offline

#10 2016-03-17 16:38:16

oliver
Administrator
Registered: 2010-11-04
Posts: 2,209

Re: [SOLVED] odd issue with theming

sinister wrote:

Basically I'm using a dark theme so one would think that when i open it normally from openbox menu, xfce4-panel, or even terminal it would be dark themed but it is not. the only way i can get it to show up dark themed is opening it through the octopi-notifier.

I just installed octopi and when I run it from the notifier, it launches it with a -style flag

octopi -style gtk

Maybe try launching it via the notifier, then run a ps to see what flags are called - then adjust the openbox menu item to match

Offline

#11 2016-03-17 18:19:39

sinister
Member
Registered: 2016-03-16
Posts: 8

Re: [SOLVED] odd issue with theming

@oliver..
Nice I didnt catch that flag when I ran the ps as you suggested a few posts up. I edited the menu entry in xfce4-panel and added -style gtk to the end and bingo it worked. In the openbox menu Octopi is listed in the Applications>System Tools pipemenu. I'm still learning about pipemenus so I'll be able to edit that entry soon enough. Thank you very much for the input. I'll mark as solved... big_smile

Offline

Board footer

Powered by FluxBB