You are not logged in.

#1 2014-04-19 16:40:50

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Gtk+3.12>3.16 and fixing compton shadows

EDIT2
Note this only effects applications using CSD (client-side-decorations, eg. gtk3-icon-browser) and compton compositor
heres a better fix  : put the below code in ~/.config/gtk-3.0/gtk-css
this way it is added to all gtk3 themes..
also if you set window-frame/border-radius  to 1,  you can grab the edges to resize > downside is black edge line and triangles on  the corners....
old##EDIT1
##heres a better fix: add/edit this to gtk3 theme gtk-widgets.css  (/theme/gtk-3.0/gtk-widgets.css)

.window-frame, .window-frame:backdrop {
  box-shadow: 0 0 0 black;
  border-style: none;
  margin: 0;
  border-radius: 0;
}

.titlebar {
  border-radius: 0;
}

making the shadow exclude stuff in compton redundant as well as fixing tiling edges in a number of wm

ORIGINAL POST
recent gtk3 update has brought some side effects to shadows of some gtk3 windows when using
compton-git for shadows. eg, gtk dialogs in spacefm.
to fix(workaround) add this to compton.conf

shadow-exclude = [ _GTK_FRAME_EXTENTS@:c ]

or command

--shadow-exclude '_GTK_FRAME_EXTENTS@:c'

also mentioned in the bug thread https://github.com/chjj/compton/issues/189 are these:

argb

_NET_WM_OPAQUE_REGION@:c

also there is a possibly related fading issue which

--fade-exclude 'argb' 

 
partly helps.....

Last edited by ncmprhnsbl (2015-06-16 19:28:49)

Offline

#2 2014-04-19 19:47:06

scjet
Member
From: Canada
Registered: 2010-12-01
Posts: 1,468

Re: Gtk+3.12>3.16 and fixing compton shadows

@ncmprhnsbl, I was gonna blame the mesa-libgl's again?,
but ahh k, thanks for that.
smile

Last edited by scjet (2014-04-19 19:49:48)

Offline

#3 2014-04-29 19:34:22

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: Gtk+3.12>3.16 and fixing compton shadows

you may be right about mesa-libgl as part of the underlying cause, i notice slighly different
behaviour between nouveau and nvidia,   and ati...

heres a another effect i just noticed:  grow/move to edge keybinds are also affected.
may be some way of excluding these in rc.xml

otherwise downgrade gtk3 or get rid of it altogether .. wink
from the gtk/gnome perspective they're implementing freedesktop.org standard that applications
should be in charge of their own window behaviour/appearance.

or live without shadows...
might check out some of the other compositers

should add.  latest compton-git includes above shadow excludes in /etc/xdg/compton.conf.example

Last edited by ncmprhnsbl (2014-04-29 19:48:53)

Offline

#4 2014-04-29 23:54:57

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,920

Re: Gtk+3.12>3.16 and fixing compton shadows

Removing gtk3 would be an option, only that would mean either using spacefm-gtk2 from aur and finding a replacement for network manager (plus a few other applications).

Marking thread as sticky as other users might have similar issues.


Comments, suggestions please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#5 2014-04-30 02:28:10

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: Gtk+3.12>3.16 and fixing compton shadows

this   :   https://aur.archlinux.org/packages/netw … plet-gtk2/   any good?  but yeah, its nigh on impossible to avoid gtk3 using official only..

Offline

#6 2014-04-30 03:15:11

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,920

Re: Gtk+3.12>3.16 and fixing compton shadows

[live@archbang ~]$ pacman -Qii gtk3
....
Required By    : deadbeef  galculator  gcr  gnome-keyring  gsimplecal  gtk-engine-unico  gucharmap  libwnck3  network-manager-applet  spacefm  volumeicon
.....

You could rebuild/remove... but our users would run into problems when they did install gtk3 applications, nothing serious of course. (spacefm-gtk2 is in aur)

For now I have to live with it... ;-)


Comments, suggestions please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#7 2014-05-02 19:16:00

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: Gtk+3.12>3.16 and fixing compton shadows

heres a better fix: add/edit this to gtk3 theme gtk-widgets.css  (/theme/gtk-3.0/gtk-widgets.css)

.window-frame, .window-frame:backdrop {
  box-shadow: 0 0 0 black;
  border-style: none;
  margin: 0;
  border-radius: 0;
}

.titlebar {
  border-radius: 0;
}

making the shadow exclude stuff in compton redundant as well as fixing tiling edges in a number of wm

edit; added to first post

Last edited by ncmprhnsbl (2014-05-02 20:27:17)

Offline

#8 2014-05-03 07:02:09

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: Gtk+3.12>3.16 and fixing compton shadows

just for fun i searched for "gtk3.12 bug"

http://redmine.audacious-media-player.o … 135?r=1160

contains a patch for GTK3.12 that turns off all client side stuff,

not sure i'd go that far,  easier to downgrade for now..

Offline

#9 2015-06-16 19:32:16

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: Gtk+3.12>3.16 and fixing compton shadows

edited first.... post added a more sensible solution

Offline

Board footer

Powered by FluxBB