You are not logged in.

#1 2015-05-11 22:24:55

UncertainPrinciples
Member
Registered: 2015-05-11
Posts: 6

Occasional black screen after Syslinux during boot

Hello all,

First time posting, just started using AB about 2 weeks ago, little bumpy but pretty awesome.
I'm not 100% sure that this issue is openbox related but here we go.

Occasionally (maybe 3/10 times) when booting right when you would expect to get the login screen I get a blank screen (no blinking cursor).
I have two options
-Open tty session and type:
1- reboot
2- xstart

Please let me know if there is some logs I could fetch to help narrow this down.

Thinkpad T440 - Most recent ArchBang - 64Bit

Thanks.

Offline

#2 2015-05-12 11:04:13

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,634
Website

Re: Occasional black screen after Syslinux during boot

If you right click, do you get to see the openbox menu?
I'm guessing you made an error editing your autostart.sh in home/user//config /openbox


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#3 2015-05-13 10:42:43

UncertainPrinciples
Member
Registered: 2015-05-11
Posts: 6

Re: Occasional black screen after Syslinux during boot

I will give this a try tonight, will report back.

Thank you.

Offline

#4 2015-05-14 19:36:53

UncertainPrinciples
Member
Registered: 2015-05-11
Posts: 6

Re: Occasional black screen after Syslinux during boot

No luck, right clicking does nothing.
I had xbindkeys in my autostart script. Will report back soon.

Offline

#5 2015-05-21 00:07:54

UncertainPrinciples
Member
Registered: 2015-05-11
Posts: 6

Re: Occasional black screen after Syslinux during boot

Still no luck. I also noticed that I get the same black screen after waking from suspend but also occasionally.

Offline

#6 2015-05-21 07:38:27

oliver
Administrator
Registered: 2010-11-04
Posts: 2,209

Re: Occasional black screen after Syslinux during boot

I wonder if you're running Xorg on vt7 or something but booting up to vt1

Are you able to hit ctrl-alt-f[1-7] and see what you get?

If you get to a login prompt, log in and run a ps to see if Openbox is running

$ ps -ef | grep -i openbox

Offline

#7 2015-05-21 22:01:16

UncertainPrinciples
Member
Registered: 2015-05-11
Posts: 6

Re: Occasional black screen after Syslinux during boot

Yes sir, output says

/usr/bin/openbox --startup /usr/lib/openbox-autostart OPENBOX

sh ~/.config/openbox/autostart (4 times)

Offline

#8 2015-05-22 07:20:03

UncertainPrinciples
Member
Registered: 2015-05-11
Posts: 6

Re: Occasional black screen after Syslinux during boot

Another observation

If it stays black after trying to wake from suspend and I close laptop lid to allow it to suspend again it doesn't. It says "on". Also ctrl+alt+f [1-7] does nothing and certain buttons on my keyboard don't work (ie mute button will no longer turn on a small led on keyboard when pressed). All this in waking from suspend. Booting allows me to open a tty and use keyboard.

Last edited by UncertainPrinciples (2015-05-22 07:26:05)

Offline

#9 2015-05-22 07:48:11

oliver
Administrator
Registered: 2010-11-04
Posts: 2,209

Re: Occasional black screen after Syslinux during boot

may be worth trying the LTS kernel just in case.

Offline

Board footer

Powered by FluxBB