You are not logged in.

#1 2013-09-12 12:53:38

hcyildiran
Member
Registered: 2013-09-10
Posts: 3

[SOLVED] I cant install vokoscreen

Hi

I'm a new user and need vokoscreen on Sunday indeed.

$ yaourt -S vokoscreen

==> Downloading vokoscreen PKGBUILD from AUR...
x PKGBUILD
x vokoscreen.install
Comment by roentgen  (2013-05-12 16:08)
The file should be 644 and the dirs 755.

I submitted a bug report at https://bugs.launchpad.net/vokoscreen/+bug/1179249

Comment by mrbit  (2013-05-12 16:15)
ok

Comment by felihommen  (2013-06-02 06:00)
Hi.
curl: (22) The requested URL returned error: 404 Not Found
and 1.6.5.1 is out.

Comment by mrbit  (2013-06-02 06:16)
ok, updated, thanks felihommen

Comment by Azul  (2013-07-16 07:22)
1.7.0 is out

vokoscreen 1.7.0-1  (Çrş Oca  2 19:40:23 EET 2013)
( Unsupported package: Potentially dangerous ! )
==> Edit PKGBUILD ? [Y/n] ("A" to abort)
==> ------------------------------------
==> n

==> vokoscreen dependencies:
 - qt4 (already installed)
 - ffmpeg (already installed)
 - lame (already installed)
 - mkvtoolnix-cli (already installed)
 - opencv (already installed)
 - cmake (already installed)
 - automoc4 (already installed)
 - gcc (already installed)


==> Edit vokoscreen.install ? [Y/n] ("A" to abort)
==> ----------------------------------------------
==> n

==> Continue building vokoscreen ? [Y/n]
==> ------------------------------------
==> 
==> Building and installing package
==> Making package: vokoscreen 1.7.0-1 (Prş Eyl 12 21:44:38 EEST 2013)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Downloading vokoscreen_1.7.0-1~precise1.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  536k  100  536k    0     0   384k      0  0:00:01  0:00:01 --:--:--  384k
  -> Found vokoscreen.install
==> Validating source files with md5sums...
    vokoscreen_1.7.0-1~precise1.tar.gz ... Passed
    vokoscreen.install ... Passed
==> Extracting sources...
  -> Extracting vokoscreen_1.7.0-1~precise1.tar.gz with bsdtar
==> Starting build()...
sh: pkg-config: command not found
Project ERROR: Package alsa not found
==> ERROR: A failure occurred in build().
    Aborting...
==> ERROR: Makepkg was unable to build vokoscreen.
==> Restart building vokoscreen ? [y/N]
==> -----------------------------------
==> 

"alsa" is already installed

$ pacman -Ss alsa
extra/alsa-firmware 1.0.27-2 [installed]
    ALSA firmware package
extra/alsa-lib 1.0.27.2-1 [installed]
    An alternative implementation of Linux sound support
extra/alsa-oss 1.0.25-1
    OSS compatibility library
extra/alsa-plugins 1.0.27-2
    Extra alsa plugins
extra/alsa-tools 1.0.27-5 [installed]
    Advanced tools for certain sound cards
extra/alsa-utils 1.0.27.2-1 [installed]
    An alternative implementation of Linux sound support
extra/alsaplayer 0.99.81-5 [installed]
    A heavily multi-threaded PCM player that tries to excercise the ALSA library
    and driver quite a bit
extra/gnome-alsamixer 0.9.7-1
    Gnome ALSA mixer
extra/pulseaudio-alsa 2-2
    ALSA Configuration for PulseAudio
community/balsa 2.5.1-1
    An e-mail client for GNOME
community/clalsadrv 2.0.0-1
    C++ wrapper around the ALSA API
community/lash 0.6.0~rc2-6
    A session management system for JACK and ALSA
community/zita-alsa-pcmi 0.2.0-1
    The successor of clalsadrv, provides easy access to ALSA PCM devices.
multilib/lib32-alsa-lib 1.0.27.2-1
    An alternative implementation of Linux sound support (32 bit)
multilib/lib32-alsa-oss 1.0.25-1
    OSS compatibility library (32 bit)
multilib/lib32-alsa-plugins 1.0.27-1
    Extra alsa plugins (32-bit)

I need help. Thank you

Last edited by hcyildiran (2013-09-13 04:20:15)

Offline

#2 2013-09-12 17:24:50

scjet
Member
Registered: 2010-12-01
Posts: 1,395

Re: [SOLVED] I cant install vokoscreen

sudo pacman -S base-devel

You need to make sure your "base-devel" group pkg is installed, it contains the "pkg-config" that you require, since your error was:

...
==> Starting build()...
sh: pkg-config: command not found
...

https://aur.archlinux.org/packages/vokoscreen/
-the maintainer should mantion that cmake, and automoc4 are also req'd dependencies of vokoscreen.

and, it's not looking for "alsa" it's simply looking for the "alsa-utils" which you already have.

Last edited by scjet (2013-09-12 17:43:11)


The "BSD" things in life are "Free of Systemd" ! ..but who knows what could happen tomorrow ?

Offline

#3 2013-09-13 04:17:37

hcyildiran
Member
Registered: 2013-09-10
Posts: 3

Re: [SOLVED] I cant install vokoscreen

Oh yes, I didn't notice it. I remember I installed base-devel and I installed dropbox and I'm using now.
Anyway, I installed base-devel and I could install vokoscreen. Thank you.

Offline

Board footer

Powered by FluxBB