You are not logged in.

#1 2013-01-25 20:40:03

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

spacefm, gtk3 & gnomish dark..

now that spacefm is now a gtk3 app..  the nature of gtk3 is harder to miss..  particularly if you like to tweak themes..one theses cases of replacing simplicity with complexity for the sake of some cool effects...
like..replace gtkrc with ..what? ..2000 lines of css..yeah thats easier..or a url link to a binary(or something)...but hey, i'm not a coder.. just an idiot user, shouldn't be touching any of this stuff ;p, must wait for a nice gui to hide all the crap underneath...  ...but y'never know, it might be good for me to learn css...

..anyway, this pic shows...at top.. gnomish-dark, gtk2 (which i liked)
                                            middle...gnomish-dark, gtk3(ok i guess, but the tabs seemed a little odd)
                                             bottom...gnomish-dark, gtk3, gnome-themes-standard.(which does something for the tabs, is it good? idk)

5lqaVoYl.jpg

Offline

#2 2013-01-26 01:10:09

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,920

Re: spacefm, gtk3 & gnomish dark..

What version of gnomish-dark are you using?

pacman -Qq gnomish-dark

Comments, suggestions please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#3 2013-01-26 05:16:24

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: spacefm, gtk3 & gnomish dark..

$ pacman -Qq gnomish-dark-theme
gnomish-dark-theme
smile
so i checked the aur and got the latest(20130123-1)...buggered if can see any difference...
i suppose what i was getting at was that 'gnome-themes-standard' supplies adwaita which is sort of a dependency.
apart from that, just having a general whinge about my inability to easily tweak(adjust background, font colours) the gtk3 part of these themes...
at least its slim log error free....

Offline

#4 2013-01-26 08:17:54

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,920

Re: spacefm, gtk3 & gnomish dark..

Sorry I meant to put

pacman -Qi | grep gnomish

I get

pacman -Qi gnomish-dark-theme
Name           : gnomish-dark-theme
Version        : 20130106-1

If you really want to mess with theme try using lxappearance. Your mileage may vary smile

I have many dark theme with ArchBang and it is difficult to get one to do all Openbox/Gtk2/Gtk3 might switch again in the near future to something with a bit more colour


Comments, suggestions please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#5 2013-01-26 18:52:20

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: spacefm, gtk3 & gnomish dark..

Mr Green wrote:

Sorry I meant to put

pacman -Qi | grep gnomish

thats makes more sense smile  , though as i say, i've now got a newer version, though i suspect the difference might only be for some gnome app or something,, which is another thing, since the people making theses gtk3 compliant themes are mostly gnome 3/shell enthusiasts, so we(minimal desktopists) end up with a lot of extranious stuff relating to gnome....
As for lxappearance, my understanding is the 'use custom colors' bit only applies to gtk2...  which i have no problem with editing the gtkrc file ...
...one more bitch:  when you change gtk2,then reload theme, changes are applied, no need to restart gtk2 apps,   not so with gtk3, apps have to restarted --this is an improvement? even 'widjet factory' --which doesn't cover everything.... sad
forgive me if i'm ranting....

Offline

#6 2013-01-27 19:18:36

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: spacefm, gtk3 & gnomish dark..

Okay...  after all that ..  i updated OMG, which seems to mostly error free now, and using that..  "D

only this error:

slim[332]: ** (deadbeef:3191): WARNING **: Can't load fallback CSS resource: Failed to import: The resource at '/org/gnome/adwaita/gtk-fallback.css' does not exist

..might try uninstalling gnome-themes-standard, and see what happens...

Offline

#7 2013-01-27 23:51:00

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,920

Re: spacefm, gtk3 & gnomish dark..

I have been looking for adwaita engine that is required for some gtk3 apps....that might get rid of the error

Try loading

sudo pacman -S gnome-themes-standard

Comments, suggestions please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#8 2013-01-28 03:04:49

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: spacefm, gtk3 & gnomish dark..

yeah, already done that.. reloaded just for the hell of it ....nope, no difference. 
gnome-themes-standard   certainly supplies adwaita 'theme'...you would expect the engine to be there somewhere...the question is : where do these gtk3 engines live?
/usr/share/gtk-engines is gtk2 only.....   and this /org/gnome/adwa....etc stuff is ..wtf..  i dont got no /org  smile

EDIT..  after digging in:  usr/share/gtk-doc/ ..found:   /usr/lib/gtk-3.0/3.0.0/theming-engines   ...has libadwaita.so and  libunico.so , which i'm guessing are engines....

Last edited by ncmprhnsbl (2013-01-28 06:25:28)

Offline

#9 2013-01-28 08:40:39

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,920

Re: spacefm, gtk3 & gnomish dark..

https://www.archlinux.org/packages/extr … -standard/

Click on Package Contents... much easier smile


Comments, suggestions please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#10 2013-01-28 16:47:10

ncmprhnsbl
Member
From: australia
Registered: 2012-12-11
Posts: 114
Website

Re: spacefm, gtk3 & gnomish dark..

ah yes.. thanks for reminding me....knew about that..but i forgets....
is quite a lot for to get one theme engine...all those icons o0....
but none the wiser.. regarding 'fallback css' message... beginning to wonder if the apps(spacefm,deadbeef,etc) themselves are calling for this nonexistent resource..

Offline

Board footer

Powered by FluxBB