You are not logged in.

#1 2011-08-01 20:45:32

kazuya
Member
Registered: 2011-01-11
Posts: 92

SOLVED failed to mount.DBus error org.gtk.Private.RemoteVolumeMonitor.

Original title was:  Failed to mount "ACER".DBus error org.gtk.Private.RemoteVolumeMonitor.
I had to modify it to stay within the 70 character title limit
oliver




I get this error message now on my archbang 64 install.
***************************************************************************
Failed to mount "ACER".
Error mounting: mount exited with exit code 21: Cannot create link /etc/mtab~
Perhaps there is a stale lock file?

and

DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending.

*******************************************************************************
I went alittle overboard with upgrading and installing different DEs.

I have the 2.6.39-ARCH (x64bit) kernel

I have google-searched and looked at a couple of links from here, archlinux forum, ubuntu forums, etc with no luck.

I have installed udev, gvfs
by issuing:
pacman -S gvfs
packer -S udiskie
pacman -S hal dbus udiskie ntfs-3g


in desperation, I also did this:
pacman -S samba smbclient

I did nano  ~/.xinitrc as root and have this configration below:
!/bin/bash
exec ck-launch-session dbus-launch openbox-session
udiskie &

What is wierd is that on my first install, everything showed fine. On thunar, dolphin and all other filemanagers, I could access the ACER NTFS partition easily. I do not know what changed.

I wonder if it is  permission issue with the drives?
I tried logining in as root to test and had the same issues.
Original title was: Failed to mount "ACER".DBus error org.gtk.Private.RemoteVolumeMonitor.
I had to modify it to stay within the 70 character limit
oliver




Somewhere someone mentioned policykit as a possible fix, but did not elaborate.( I shall check the wiki again.)

There is also ntfs-config from AUR.

This is my fstab configuration: (nano /etc/fstab) as root:
#
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
devpts                 /dev/pts      devpts    defaults            0      0
shm                    /dev/shm      tmpfs     nodev,nosuid        0      0
UUID=6f60b7b1-d97d-4098-8580-7bc07d0c1939 / ext4 defaults 0 1
UUID=74c38398-b5aa-4da9-900b-eaab606452d1 swap swap defaults 0 0
UUID=cc3db9ef-cf90-4d42-8b85-440774fc5493 /home ext4 defaults 0 1
UUID=ede40a98-7df3-4fd5-92c9-bbe29a361005 /Data1 ext3 defaults 0 1

EDIT:
This is appearing to be a user error on my part.

When logged on as root, I can acess the drive easily with no issues.
Question is how to setup partitions to easily viewed and even read/wrote on by certain user accounts.

Last edited by oliver (2011-08-02 07:12:39)

Offline

#2 2011-08-01 21:37:40

kazuya
Member
Registered: 2011-01-11
Posts: 92

Re: SOLVED failed to mount.DBus error org.gtk.Private.RemoteVolumeMonitor.

Sorry for wasting you guys time.
Easy solution was to do the following:

pacman -Sy
yaourt -S ntfs-config

Once ntfs-config is installed, you simply call it up from
System menu > NTFS Configuration Tool

You can then do auto configuration on the ntfs partitions in question. This easily got my problems all solved.

My /etc/fstab file now looks like this:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>

devpts  /dev/pts        devpts  defaults        0       0
#Entry for /dev/sda6 :
UUID=6f60b7b1-d97d-4098-8580-7bc07d0c1939       /       ext4    defaults       $
#Entry for /dev/sda8 :
UUID=ede40a98-7df3-4fd5-92c9-bbe29a361005       /Data1  ext3    defaults       $
#Entry for /dev/sda7 :
UUID=cc3db9ef-cf90-4d42-8b85-440774fc5493       /home   ext4    defaults       $
#Entry for /dev/sda2 :
UUID=B62A1C152A1BD16B   /media/ACER     ntfs-3g defaults,nosuid,nodev,locale=en$
#Entry for /dev/sda1 :
UUID=72BCF6BABCF67845   /media/PQSERVICE        ntfs-3g defaults,locale=en_US.u$
shm     /dev/shm        tmpfs   nodev,nosuid    0       0
#Entry for /dev/sda5 :
UUID=74c38398-b5aa-4da9-900b-eaab606452d1       swap    swap    defaults       $


Notice that the ACER partition got added to my fstab.
It would be nice if in the future, prior to install, an option for ntfs format for partition be available. This option tends to be absent in arch and archbang. The installer forces us to mount the ntfs partitions later.

Offline

#3 2011-08-02 07:08:32

oliver
Administrator
Registered: 2010-11-04
Posts: 1,903

Re: SOLVED failed to mount.DBus error org.gtk.Private.RemoteVolumeMonitor.

thanks for updating.  I'll mark the topic as solved

Offline

Board footer

Powered by FluxBB