You are not logged in.

#1 2015-02-26 18:08:20

Registered: 2014-07-12
Posts: 5

booting issue: "device not accepting address" error

I have install Archbang on a USB3 SSD.  But most times I get an error when I try to boot... something like:
   triggering uevents
  ... usb device not accepting address 2, error -22
  and then it drops to shell after 10 sec delay

Before installing Archbang I briefly had used a different distro with Archlinux and I don't recall ever having this issue.  I've Googled this issue and tried many things to solve this... some of them:
1) installing the LTS kernel instead of the most recent dev version. (it only seemed to resolve the backlight error that I was getting)
2) I tried different boot options in the systlinux.conf file (I am not using Grub) and I use the bios option (F12) to select OS)
3) I even tried changing the order of the hooks in udev (I found some discussion regarding this being an issue with "device not accepting address)
4) someplace I read that my SSD is broken, but I don't agree with this, as I've been able to run other Linux distros without problems
5) I may have tried other things, but I don't remember right now...

The one (only) way that I get Archbang to boot is: F12 at boot-> select USB boot -> unplug SSD, wait abt 5-10 sec, plugin SSD -> will boot about 80% of the time (if not I reboot and go through the sequence again).

EDIT one month later:  This is still an issue for me, so any suggestions would be appreciated.

Last edited by TJMcK (2015-03-28 18:04:20)


Board footer

Powered by FluxBB