You are not logged in.

#1 2015-02-24 20:17:26

not_my_usual
Member
Registered: 2015-02-24
Posts: 2

[Solved] SLIM failed to execute login command

Hi I've been using archbang for a while, but today my laptop freezed and i had to do a soft reset and rebooted and now I couldnt login using slim with my normal user
I logged in a TTY and have done the following to no avail:

  • deleted slim lock 

    rm /var/lock/slim.lock
  • checked slim logs

  • checked .xinitrc for errors

    #!/bin/bash
    export BROWSER=firefox
    export DE=openbox
    exec dbus-launch openbox-session
  • disabled slim

    sudo systemctl disable slim.service

    to try and startx or xinit

  • enabled slim again and uninstall and install again via pacman

But still havent been able to get it to work
I can login as root via slim just not my regular user

Any help is appreciated, thanks!

Last edited by not_my_usual (2015-02-24 21:22:12)

Offline

#2 2015-02-24 21:33:08

not_my_usual
Member
Registered: 2015-02-24
Posts: 2

Re: [Solved] SLIM failed to execute login command

I solved this, what was happening was that after the laptop crashed it made a couple huge coredump files (2 gig files)
So when I tried to start with my user which has postgresql server, it couldn't write to some files because there was no space in disk so postgresql start failed and so the whole slim login failed.

To make it work I deleted the coredump files to free some space and it solved it.

Offline

Board footer

Powered by FluxBB