You are not logged in.

#1 2013-03-09 15:32:16

Registered: 2013-01-14
Posts: 20

[SOLVED]Can't get ncmpcpp visualiser to start

Not sure if this is the right sub forum but here goes.

I have mpd working with ncmpcpp-git but I can not get the visualiser to start. It keeps saying
can not open mpd.fifo for reading PCM data. No such file or directory.

my ncmpcpp config is

mpd_host                   = "localhost"
mpd_port                   = "6600"
mpd_music_dir              = "~/Music"
mpd_crossfade_time         = "1"
visualizer_in_stereo       = "yes"
visualizer_fifo_path       = "~/.mpd/mpd.fifo"
visualizer_output_name     = "my_fifo"
visualizer_type            = "spectrum"                          # spectrum/wave

and my mpd conf is

music_directory "~/Music"
playlist_directory  "~/.mpd/playlists"
db_file "~/.mpd/mpd.db"
log_file "~/.mpd/mpd.log"
user "axj"
group "users"
bind_to_address "localhost"
port "6600"

audio_output {
        type            "alsa"
        name            "My Sound Card"
        mixer_type      "software"      # optional
        mixer_device    "default"    # optional
        mixer_control    "PCM"        # optional
        mixer_index    "0"        # optional

audio_output {
    type                    "fifo"
    name                    "my_fifo"
    path                    "~/.mpd/mpd.fifo"
    format                  "44100:16:2"

Any ideas ? Ive tried the arch wiki and seen examples , also did chmod 777 on the mpd.fifo file but still hmm


Last edited by ayushjsh (2013-03-09 20:05:27)


#2 2013-03-09 19:02:20

Registered: 2012-12-18
Posts: 27

Re: [SOLVED]Can't get ncmpcpp visualiser to start


I can't find any mistake in your config.
How about changing the path '/.mpd/mpd.fifo' into '/tmp/mpd.fifo in your mpd and ncmpcpp conf?

I'm using mpd ver.0.17.3 & ncmpcpp ver.0.5.10 installed from pacman community repo.
The visualiser works well both with alsa and jack output.

my config is:

--- .mpdconf ---
audio_output {
        type                    "fifo"
        name                    "FIFO"
        path                    "/tmp/mpd.fifo"
		format                  "44100:16:2"

--- .ncmpcpp/config ---
visualizer_output_name = "FIFO"
visualizer_in_stereo = "yes"
visualizer_fifo_path = "/tmp/mpd.fifo"
visualizer_sync_interval = "1"
visualizer_type = "wave" (spectrum/wave)

*I'm not using crossfade option.

Maybe it had better have posted to Hardware & Multimedia smile

Thank you Mr. Ziggy Stardust! I've been waiting for 10 years.


#3 2013-03-09 20:05:07

Registered: 2013-01-14
Posts: 20

Re: [SOLVED]Can't get ncmpcpp visualiser to start

Cheers mate , figured it it out now.
had to change that fifo to /tmp/mpd.fifo
also had to put
visualizer_look = "+|"
without which it would be just a blank screen !!!



Board footer

Powered by FluxBB