You are not logged in.

#1 2012-04-05 10:33:03

chamber
Member
Registered: 2012-04-05
Posts: 6

[SOLVED] changing desktop environment

I was wondering if it was possible to change the default from openbox to subtle?

I have attempted to do this but when I add

Exec subtle

To my .xinitrc it just fails to log me in, running subtle --replace just brings me back to the slim log in.

Has anyone had any success with this or would they know of any issues?

Last edited by chamber (2012-04-06 04:17:16)


"All right amatuer hour's over. Let me show you why they call me the Velour Fog...."

Offline

#2 2012-04-05 11:50:22

Kruppt
Moderator
From: Blue Ridge Mountains, NC
Registered: 2010-12-20
Posts: 299

Re: [SOLVED] changing desktop environment

If Using Slim as login manager you would need to add subtle to the session line in the /etc/slim.conf file.
If you are not planning to use a login manager, search this forum, there have been several good posts dealing with this issue on this forum.

Offline

#3 2012-04-05 12:37:52

chamber
Member
Registered: 2012-04-05
Posts: 6

Re: [SOLVED] changing desktop environment

Thanks, will have a check on that. Was planning on using slim anyway. Forgot about the slim.conf file.

Will have a play about over the weekend.


"All right amatuer hour's over. Let me show you why they call me the Velour Fog...."

Offline

#4 2012-04-06 03:43:17

chamber
Member
Registered: 2012-04-05
Posts: 6

Re: [SOLVED] changing desktop environment

No joy, added subtle to slim.conf and this had the same effect.

.xinitrc

#!/bin/bash

#export BROWSER=firefox-aurora
#export DE=xfce
#exec ck-launch-session dbus-launch openbox-session
nitrogen --restore &
exec ck-launch-session dbus-launch subtle

slim.conf

# Path, X server and arguments (if needed)
# Note: -xauth $authfile is automatically appended
default_path        ./:/bin:/usr/bin:/usr/local/bin
default_xserver     /usr/bin/X
xserver_arguments   -nolisten tcp vt07

# Commands for halt, login, etc.
halt_cmd            /sbin/shutdown -h now
reboot_cmd          /sbin/shutdown -r now
console_cmd         /usr/bin/xterm -C -fg white -bg black +sb -T "Console login" -e /bin/sh -c "/bin/cat /etc/issue; exec /bin/login"
#suspend_cmd        /usr/sbin/suspend

# Full path to the xauth binary
xauth_path         /usr/bin/xauth 

# Xauth file for server
authfile           /var/run/slim.auth


# Activate numlock when slim starts. Valid values: on|off
# numlock             on

# Hide the mouse cursor (note: does not work with some WMs).
# Valid values: true|false
# hidecursor          false

# This command is executed after a succesful login.
# you can place the %session and %theme variables
# to handle launching of specific commands in .xinitrc
# depending of chosen session and slim theme
#
# NOTE: if your system does not have bash you need
# to adjust the command according to your preferred shell,
# i.e. for freebsd use:
# login_cmd           exec /bin/sh - ~/.xinitrc %session
login_cmd           exec /bin/bash -login ~/.xinitrc %session

# Commands executed when starting and exiting a session.
# They can be used for registering a X11 session with
# sessreg. You can use the %user variable
#
# sessionstart_cmd	some command
# sessionstop_cmd	some command

# Start in daemon mode. Valid values: yes | no
# Note that this can be overriden by the command line
# options "-d" and "-nodaemon"
# daemon	yes

# Available sessions (first one is the default).
# The current chosen session name is replaced in the login_cmd
# above, so your login command can handle different sessions.
# see the xinitrc.sample file shipped with slim sources
sessions            subtle,xfce4,icewm,wmaker,blackbox

# Executed when pressing F11 (requires imagemagick)
screenshot_cmd      import -window root /slim.png

# welcome message. Available variables: %host, %domain
welcome_msg         Welcome to %host

# Session message. Prepended to the session name when pressing F1
# session_msg         Session: 

# shutdown / reboot messages
shutdown_msg       The system is halting...
reboot_msg         The system is rebooting...

# default user, leave blank or remove this line
# for avoid pre-loading the username.
#default_user        simone

# Focus the password field on start when default_user is set
# Set to "yes" to enable this feature
#focus_password      no

# Automatically login the default user (without entering
# the password. Set to "yes" to enable this feature
#auto_login          no


# current theme, use comma separated list to specify a set to 
# randomly choose from
current_theme       archbang

# Lock file
lockfile            /var/lock/slim.lock

# Log file
logfile             /var/log/slim.log

This works on my arch vm without modifying the slim.conf file, here is the .xinitrc file from that

#!/bin/sh
#
# ~/.xinitrc
#
# Executed by startx (run your window manager from here)
#
#if [ -d /etc/X11/xinit/xinitrc.d ]; then
#  for f in /etc/X11/xinit/xinitrc.d/*; do
#    [ -x "$f" ] && . "$f"
#  done
#  unset f
#fi
#
# exec gnome-session
# exec startkde
# exec startxfce4
# ...or the Window Manager of your choice
#exec ck-launch-session dbus-launch openbox-session
sh ~/.fehbg &
exec ck-launch-session dbus-launch subtle
xrdb -merge ~/.Xresources

Anyone have any thoughts?


"All right amatuer hour's over. Let me show you why they call me the Velour Fog...."

Offline

#5 2012-04-06 04:16:50

chamber
Member
Registered: 2012-04-05
Posts: 6

Re: [SOLVED] changing desktop environment

Nevermind.  Got it working.  Issue was with lancher.rb


"All right amatuer hour's over. Let me show you why they call me the Velour Fog...."

Offline

Board footer

Powered by FluxBB