You are not logged in.

#1 2011-11-30 09:27:41

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

[Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Yay! My new netbook got this after the first update of all packages:

[drm:intel_lvds_enable] *ERROR* timed out waiting for panel to power on

The fun part is you open a console and it is also greatly distorted too so I'm googling and getting frustrated. Writing this from Sabayon which seems to have no problems. Will report back later when I can figure out what intel whatever I have.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#2 2011-11-30 14:00:06

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,129
Website

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Let me know if you want help.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#3 2011-12-01 03:18:07

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Trying linux-ck kernel. No problem with other distros. Loop turns on and off correctly in the other distros but with my new laptop, no. Kernel panics are just part of the fun. Apparently graysky's new linux-ck has the patch so I'll try that. I don't know about anyone else but I feel that Arch is getting worse. The more they try to fix and upgrade coding, etc. the more problems are occuring.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#4 2011-12-01 03:47:42

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,129
Website

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

I feel that Arch is getting worse. The more they try to fix and upgrade coding, etc. the more problems are occuring.

Maybe.. listen, I say maybe, the problem is also that you always seem to flee forwards or sideways and never backwards like I do when I have problems.
Have you tried that, reinstalling the older kernel??
Maybe it  is for sissies but I don't care as long as I have a functional system.
By downgrading you buy time.
And after a few weeks the problems will be sorted out.
If you're lucky.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#5 2011-12-01 04:19:41

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

In the old days I used to run two kernels for that reason, when the latest and greatest broke and I simply switched to most recent one. Which in other words is the same as what pablokal is saying.

Have just set up my system ready to install Archbang [main desktop] but am still wary on doing it.

Mint 12 ran fine for ten minutes then I got bored!

Ok could run lxde/openbox but why have Shell/Unity/Mate the kitchen sink installed.

Give it a couple weeks and Arch will come good smile

Offline

#6 2011-12-01 04:52:47

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Going backwards back to the 3.0 kernel is my second plan. I will try Con's kernel first and if it doesn't work then go back to 3.0 and then try upgrading when the next kernel is released.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#7 2011-12-01 12:19:04

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Upgraded and tried the new 3.1.4.1 kernel and no luck. Downgraded to Linux 3.0.4-1 and no more error. I guess you can add this error to my list of not impressed by the 3.1 kernel thread.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#8 2011-12-01 20:01:19

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

No more error but the kernel panics haven't stopped. More work to do sad


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#9 2011-12-02 00:58:29

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Just had a look on Arch forums for kernel stuff looks a complete mess....

Maybe we should have our own kernel

Seen lts in AUR but its way out of date

Is Arch releasing kernels just to be ahead of the game?

Offline

#10 2011-12-02 01:17:23

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

There are up to date LTS kernels being released around once or twice a month. I think I'll try it. I'm not sure but I think things starting going downhill after removing aufs. The distros I have loaded that have no problems still use aufs and hal. So much for deprecation. I do think these kernels are being released too soon. Sometimes, they are in and out of testing in a matter of hours.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#11 2011-12-02 04:41:02

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,129
Website

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

I would try linux-3.0.1-1.
And hal you can install; it is not an interfering dependency.
I also have hal installed.
You don't have to include hal in your daemons list in rc.conf if you have dbus there; as dbus automatically launches hal.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#12 2011-12-02 06:52:32

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

I am running 3.0.1-1 now. We'll see after a couple of hours whether it works.  Just to give you guys an idea of my intel stuff

$ lspci
00:00.0 Host bridge: Intel Corporation N10 Family DMI Bridge (rev 02)
00:02.0 VGA compatible controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation N10 Family Integrated Graphics Controller (rev 02)
00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
00:1d.0 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #3 (rev 02)
00:1d.3 USB controller: Intel Corporation N10/ICH 7 Family USB UHCI Controller #4 (rev 02)
00:1d.7 USB controller: Intel Corporation N10/ICH 7 Family USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation NM10 Family LPC Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation N10/ICH7 Family SATA AHCI Controller (rev 02)
00:1f.3 SMBus: Intel Corporation N10/ICH 7 Family SMBus Controller (rev 02)
01:00.0 Ethernet controller: Atheros Communications AR8152 v2.0 Fast Ethernet (rev c1)
02:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)

and

$ lsmod
Module                  Size  Used by
ppp_deflate             3398  0 
zlib_deflate           18070  1 ppp_deflate
bsd_comp                4615  0 
ppp_async               5982  1 
crc_ccitt               1095  1 ppp_async
ppp_generic            19617  7 ppp_deflate,bsd_comp,ppp_async
slhc                    4261  1 ppp_generic
fuse                   58597  2 
sr_mod                 13244  0 
cdrom                  31277  1 sr_mod
option                 13362  3 
uvcvideo               57363  0 
usb_wwan                7798  1 option
usbserial              26639  9 option,usb_wwan
uas                     6440  0 
usb_storage            35183  0 
videodev               70542  1 uvcvideo
joydev                  7439  0 
media                   8545  2 uvcvideo,videodev
arc4                    1086  2 
ath9k                  75574  0 
mac80211              191509  1 ath9k
snd_hda_codec_realtek   222124  1 
eeepc_wmi               1783  0 
ath9k_common            1390  1 ath9k
snd_hda_intel          19101  1 
snd_hda_codec          66954  2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep               4942  1 snd_hda_codec
snd_pcm                60015  2 snd_hda_intel,snd_hda_codec
asus_wmi               11372  1 eeepc_wmi
sparse_keymap           2628  1 asus_wmi
pci_hotplug            22322  1 asus_wmi
processor              21876  0 
ath9k_hw              262580  2 ath9k,ath9k_common
ath                    11959  2 ath9k,ath9k_hw
cfg80211              138620  3 ath9k,mac80211,ath
i2c_i801                7063  0 
snd_timer              15374  1 snd_pcm
snd                    43593  8 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
serio_raw               3390  0 
iTCO_wdt               10293  0 
rfkill                 12406  2 asus_wmi,cfg80211
soundcore               4986  1 snd
psmouse                56431  0 
snd_page_alloc          5869  2 snd_hda_intel,snd_pcm
atl1c                  28528  0 
battery                 8865  0 
ac                      2505  0 
iTCO_vendor_support     1545  1 iTCO_wdt
thermal                 6595  0 
evdev                   7278  11 
wmi                     7295  1 asus_wmi
ext4                  337724  2 
mbcache                 4249  1 ext4
jbd2                   59488  1 ext4
crc16                   1069  1 ext4
usbhid                 31199  0 
hid                    65215  1 usbhid
sd_mod                 26147  3 
ahci                   18085  2 
uhci_hcd               19609  0 
libahci                16573  1 ahci
libata                154449  2 ahci,libahci
scsi_mod              111801  5 sr_mod,uas,usb_storage,sd_mod,libata
ehci_hcd               34935  0 
usbcore               119612  10 option,uvcvideo,usb_wwan,usbserial,uas,usb_storage,usbhid,uhci_hcd,ehci_hcd
i915                  612452  3 
drm_kms_helper         21997  1 i915
drm                   147613  4 i915,drm_kms_helper
intel_agp               8720  1 i915
i2c_algo_bit            4423  1 i915
button                  3646  1 i915
intel_gtt              11417  3 i915,intel_agp
agpgart                22096  3 drm,intel_agp,intel_gtt
i2c_core               16625  6 videodev,i2c_i801,i915,drm_kms_helper,drm,i2c_algo_bit
video                   9780  1 i915

and

$ lspci -k | grep rt
    Kernel driver in use: agpgart-intel
00:1c.0 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 1 (rev 02)
    Kernel driver in use: pcieport
00:1c.1 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 2 (rev 02)
    Kernel driver in use: pcieport
00:1c.2 PCI bridge: Intel Corporation N10/ICH 7 Family PCI Express Port 3 (rev 02)
    Kernel driver in use: pcieport 

and

$ lsmod | grep rt
iTCO_vendor_support     1545  1 iTCO_wdt
agpgart                22096  3 drm,intel_agp,intel_gtt

GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#13 2011-12-02 08:48:26

oliver
Administrator
Registered: 2010-11-04
Posts: 1,862

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Mr Green wrote:

Maybe we should have our own kernel

Not sure AB needs it's own kernel since the official Arch one includes pretty much everything as a module.  I've often wondered though whether you could get pacman.conf to source another config file (lets say, archbang,conf) that would hold back certain packages or "upgrade" the artwork and convert AB "Winter" to AB "Summer" if you so desired.

Can't say I've really thought about this too much tough

Offline

#14 2011-12-02 09:24:04

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Well an Archbang kernel for live version would something but as you say once you install you are at the mercy of Arch version.

Had not thought it through either smile

Almost tempted to build a kernel, well almost

Not all that keen about rolling back packages or kernels, sure its a fix but only a band aid on large hole

Offline

#15 2011-12-02 09:35:10

oliver
Administrator
Registered: 2010-11-04
Posts: 1,862

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Mr Green wrote:

Almost tempted to build a kernel, well almost

:-)  It's only really painful the first time

I'm using a modified version of linux-fbcondecor from AUR.  Each time an update comes down, I modify the PKGBUILD so it runs 'make oldconfig'.  My finished kernel pkg is about 12mb now

Offline

#16 2011-12-02 09:42:09

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

How long does a kernel take to build for you? Will give it a go. ... .

Offline

#17 2011-12-02 11:19:11

oliver
Administrator
Registered: 2010-11-04
Posts: 1,862

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

about 15 minutes I guess... it did take a good 5 or 6 goes though before I got everything going right

I used Pappys kernel seeds web page as my reference guide
http://kernel-seeds.org/settings-01.html

Basically, I installed linux-fbcondecor and edited the PKGBUILD to use 'make xconfig'... then I put the current /proc/config.gz settings in... then used Pappy's site to remove anything unneeded..

Now when new updates come I do the 'make oldconfig' edit

Offline

#18 2011-12-02 12:52:15

mike4ca
Happy (Arch|Manjaro)[B,b]ang User
From: Iowa, USA
Registered: 2011-10-17
Posts: 435

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

oliver wrote:
Mr Green wrote:

Almost tempted to build a kernel, well almost

:-)  It's only really painful the first time

I'm using a modified version of linux-fbcondecor from AUR.  Each time an update comes down, I modify the PKGBUILD so it runs 'make oldconfig'.  My finished kernel pkg is about 12mb now

Sounds like a good topic for a wiki article.  Something I would definitely be interested in.  I tried Gentoo and went through the Kernel build process.  You learn a lot about the hardware.  If you start a wiki topic, I will review and test it!


Free Software Foundation member 10865

Offline

#19 2011-12-02 18:49:07

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

It does sound like a good topic and it looks like I'm going to have to build my own kernel because recent Arch kernels aren't showing my new netbook any love. So I guess I'll have something new to add to the Wiki next week wink


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#20 2011-12-03 02:54:46

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Using https://aur.archlinux.org/packages.php?ID=34625, the kernel-netbook from AUR. It's supposed to be customized for netbooks with Intel (mine being Intel® Atom™ N570 dual core for the eeepc Asus 1215P). More about the kernel at http://code.google.com/p/kernel-netbook/

So far, so good.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#21 2011-12-06 03:30:11

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Ripped out everything and started over fresh. ArchBang is the only distro now. Loopback problem stopped but still get the occasional kernel panic. I will not let this beat me and will find a solution. Better to run Arch with kernel panics than use some other distro (besides Gentoo). One thing all these installs of different distros installed in the last week has taught me is that despite some of Arch's shortcomings, it's head and shoulders above the rest (besides Gentoo).


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#22 2011-12-06 04:17:21

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Going to install arch on a second drive over next few days, not ready to trust it as my main desktop yet.

Ran lubuntu with 3.2 kernel under virtualbox with no problem, but VB uses generic drivers.

Not sure how Archbang will cope with my super computer smile

Offline

#23 2011-12-06 21:44:55

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Can't even stop the kernel panics long enough to download the kernel-netbook kernel. What really gets me is all other distros have no problem. Why Arch? Too vanilla I guess and not enough patches. Even Con's linux-ck didn't stop the panics. The hardware of an Asus 1215P Atom 570 Duo Core AND Arch don't like each other. Downloading LMDE right now but thinking about Funtoo. Sylvain from Funtoo Quebec is running Openbox on his Funtoo and they have added extra OB packages to Gentoo (oblogout, etc.). I know "Gentoo" works on this netbook.

If I add LMDE (XFCE) I'll see if I can OBify it. MintBang? hahaha!! Or maybe LXDE. Not keen on xfce and thunar.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#24 2011-12-07 00:01:03

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

If you can run Archbang live on your laptop you could chroot the kernel-netbook kernel or pacman -r into it ? [possibly]

Offline

#25 2011-12-07 01:06:39

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

It had kernel panics last time I used kernel-netbook so it was no big deal that I couldn't download it again for the fresh install. What bothers me is, "What are the other distros doing right that Arch seems to be doing wrong for my netbook?" Why only Arch? I believe it's a kworker problem although not much of anything appears as errors in the logs to help me fix the problem. I thought it also might be a USB problem but I get kernel panics even when no PnP device or usb modem is attached. It might be the Intel graphics driver but again, why only with Arch? Just finished reading some Forums with the same problems and these have been fixed already in a kernel upgrade. Explains probably why the other distros work and Arch doesn't.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#26 2011-12-07 01:23:09

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

I wonder if I blacklisted asus_acpi? Hmmmm?? Just thinking out loud.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#27 2011-12-07 07:37:41

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

https://wiki.archlinux.org/index.php/Asus_EEE_PC_1215n

People will buy exotic new state of the art hardware.....

Arch runs fine on a 386 Pentium II with 48mb of ram and a 2gb hard drive!!!

Offline

#28 2011-12-07 22:35:28

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Well, I finally gave up. I compiled my own kernel with patches and it still wouldn't work properly. I will run AB in VB on this netbook. I have installed the netbook version of Sabayon 7 KDE. I tried LMDE with XFCE (ripping out the XFCE and replacing it with LXDE of course) and it ran nice and was loaded with a lot of stuff (some I removed to lighten the bloat) but it just felt kind of blah!! I will stick with what I have now. Still haven't finished configuring to keep the desktop out of my way so I can do my work without too many clicks. I keep clicking on the desktop waiting for the obmenu to appear. lol It looks really nice but it's just not as fast as AB. Equo has decent speed but it's not pacman. Sulfur/Entropy Store is slower than molasses running uphill in winter and I will be avoiding it like the plague.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#29 2011-12-08 04:32:32

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,129
Website

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

it's just not as fast as AB

I never experienced a KDE environment that was as responsive as I would like; my best experience with fastness was Sabayon but had too much hangups there. That kills any alternative for me.
That is the problem with Arch plus Openbox, if you get used of the lack of latency, the direct appearance of applications, the fastness of operations, every other DE feels so damn slow.
I have nearly the same quickness with Debian and openbox; I have now livarp/squeeze and aptosid+ OB; and I have yet to compare them both for fastness.  My first impression is that aptosid is just a fraction faster, but livarp+OB isn't slow either.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#30 2011-12-08 05:07:23

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

I completely agree with you. I had to take out Sabayon KDE. Once I updated I got reminders of why I left it years ago and why it's KDE (Krash Desktop Environment). LMDE is back in and getting updated now. I'll LXify it when I get home after lecturing. Waiting for siduction to give a try in VBox.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#31 2011-12-08 07:40:51

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

2011-11-09 4:42:01
Press Release: Sabayon Linux 7 Experimental Releases

Directly from our "Breaking Stuff" dept., three new Sabayon 7 releases have seen the light!
These releases all go under the "Experimental" umbrella, not that because

    LXDE is a minimal, CD-sized flavour geared towards low-end computers, shipping the LXDE Desktop Environment.

From Sabayon home page....

Offline

#32 2011-12-08 09:05:41

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

I already have Sabayon LXDE running on my kids laptop. It's pretty solid and that's why it's in there. I use portage and not equo to update. It's lacking some stuff that Arch has for LXDE but that's stuff I need if I'm running LXDE.
About to download the tarball and install lxmed, the menu editor for LXDE and install on LMDE. I need to liven it up a bit though so maybe pablokal or someone can post Debian's unstable repositories for me to add to the source list.  wink


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#33 2011-12-08 09:26:21

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Got Sabayon 7 Lxde running under Virtualbox no real surprises, very easy install.....

Depain is so 80's!

Offline

#34 2011-12-10 04:45:56

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Coming at you live from ArchBang on Asus 1215P finally!!!! Running my customized kernel (kernel-netbook-av) with everything but the kitchen sink blacklisted and patched. 11 days to get this done. And what did I learn? A helluvalot and also that a lot of new machines are crap and old hardware rules!!!


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#35 2011-12-10 06:24:00

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

I am old hardware does that mean I rule?

Well done all your hard work has paid off, now that kernel is out of you need to compile I new one smile

Offline

#36 2011-12-10 13:49:52

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,129
Website

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Would it be  possible to describe the essential steps for solving this for this hardware?
So other wise men who were fooled in thinking Asus provides great hardware, may be able to use the 1215p with Arch?


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#37 2011-12-10 19:06:32

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

To be honest, I did so much, especially during the last few days with the kernel tweaking until I have it working correctly, blacklisting, patches, frame buffers, modules, upgrading BIOS, trying and deleting eeepc stuff from the AUR, giving up several times then not admitting defeat, etc. that it is really not possible document all my steps. There are a lot of issues especially with the CPU, data transfer fails, machine not syncing, frame buffers, ACPI, MCE panics, invalid levels, etc. and dmesg log, etc. doesn't give a lot of information on the problem that caused a kernel panic on this machine. My success came down to a lot of guess work, trying stuff from Arch Forums and Wiki (which really didn't help) and fixing mistakes I made.

The kernel-netbook works well for Intel Atom netbooks but doesn't support my processor yet so I had to tweak it to take care of some issues it wasn't patched for. "Make oldconfig" will be my best friend for the kernel-netbook-av.

Is it possible to run the Asus 1215P with Arch? Yes. Is it easy? Hell, no! There are too many other distros that will work OOTB on this netbook and perform awesomely so IMHO, it's better to run something else other than Arch.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#38 2011-12-11 01:14:16

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

At the very least the spec of the 1215p you have, did have a look and their many different versions.

Be interesting to know tpowas take on it.....

Offline

#39 2011-12-11 03:27:33

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

My 1215P is not the same as the one on the internet on the Asus site http://www.asus.com/Eee/Eee_PC/Eee_PC_1 … ifications. It has an Intel Atom N570 @1.66 Duo core processor and I just found out it is Intel 64. DOH!!!!!!!! brick-wall-017.gif Running the 32 bit ArchBang on this machine.

archvortex@ArchVortex ~ $ grep "^flags.*\blm\b" /proc/cpuinfo
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dts tpr_shadow vnmi flexpriority
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dts tpr_shadow vnmi flexpriority
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dts tpr_shadow vnmi flexpriority
flags		: fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx lm constant_tsc arch_perfmon pebs bts aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm movbe lahf_lm dts tpr_shadow vnmi flexpriority

Hello lm flag!! My processor is x86_64 compatible. Maybe running it on a 64-bit ArchBang might make a difference.... ya think? Excuse me while I go submit myself for Japanese game show punishment.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#40 2011-12-11 06:49:52

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,129
Website

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

I already thought it would  a hell of a job to get it running, with trying different scenarios, keeping some elements, discarding others, I've been there.
Yes, that's how life goes...make  a good back up before you try 64 bits settings!!
If I know you a bit, you won't be able to resist to try.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#41 2011-12-11 08:49:28

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

You're right! I won't be able to resist to try and stubbornly won't stop until until I get it figured out. That I guess, is the hacker in me. I tried installing the 64 bit on an extra partition and it kept crashing during installation. New project!! My 32-bit is running perfectly now. No panics all day smile


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#42 2011-12-14 02:03:48

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Panics came back. My processor is an Intel 64 running 32 bit (it runs both). If the RAM is only up to 2GB then it runs as a 32-bit. If the laptop (not netbook) can run 4GB RAM and has 4GB of RAM then it runs as 64-bit. Anyways, because it runs duo-core and 4 threads, it shows as having 4 processors ( CPU 0, CPU 1, CPU 2, CPU 3). I still get MCE panics with machine not syncing so what I plan to do is change the cpu processor setting in my custom kernel and only run 3 processors instead of 4. I read that this has fixed the problem for people with the same problem. They have been able to change the number of processors at the BIOS but I have no such setting so I will do it through the kernel as I remember there is a setting for it. The fun continues roll


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#43 2011-12-14 05:57:33

oliver
Administrator
Registered: 2010-11-04
Posts: 1,862

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

ArchVortex wrote:

Panics came back. My processor is an Intel 64 running 32 bit (it runs both). If the RAM is only up to 2GB then it runs as a 32-bit. If the laptop (not netbook) can run 4GB RAM and has 4GB of RAM then it runs as 64-bit. Anyways, because it runs duo-core and 4 threads, it shows as having 4 processors ( CPU 0, CPU 1, CPU 2, CPU 3). I still get MCE panics with machine not syncing so what I plan to do is change the cpu processor setting in my custom kernel and only run 3 processors instead of 4. I read that this has fixed the problem for people with the same problem. They have been able to change the number of processors at the BIOS but I have no such setting so I will do it through the kernel as I remember there is a setting for it. The fun continues roll

echo 0 > /sys/devices/system/cpu/cpu3/online

might do it... as long as you can set it before the panic

Offline

#44 2011-12-14 07:16:59

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

http://www.laptopspark.com/products/ASU … 31330.html

Something more like this....

Can you update BIOS on Laptops?

Offline

#45 2011-12-14 08:38:38

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

BIOS doesn't need an update.

Interesting that my dirty Gentoo install does this if I run

 cpu-freq info 

and get

gentoovortex@GentooVortex ~ $ cpufreq-info
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, powersave, userspace, performance
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz.
  cpufreq stats: 1.67 GHz:11.35%, 1.33 GHz:0.60%, 1000 MHz:88.05%  (5503)
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, powersave, userspace, performance
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz.
  cpufreq stats: 1.67 GHz:11.53%, 1.33 GHz:0.55%, 1000 MHz:87.92%  (5721)
analyzing CPU 2:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 2
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, powersave, userspace, performance
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz.
  cpufreq stats: 1.67 GHz:9.00%, 1.33 GHz:0.34%, 1000 MHz:90.66%  (4414)
analyzing CPU 3:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 3
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, powersave, userspace, performance
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 1000 MHz.
  cpufreq stats: 1.67 GHz:12.91%, 1.33 GHz:0.42%, 1000 MHz:86.66%  (5053) 

but if I run it for ArchBang or Arch

[archvortex@ArchVortex ~]$ cpufreq-info
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 1.67 GHz.
analyzing CPU 1:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 1
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 1.67 GHz.
analyzing CPU 2:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 2
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 1.67 GHz.
analyzing CPU 3:
  driver: acpi-cpufreq
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 3
  maximum transition latency: 10.0 us.
  hardware limits: 1000 MHz - 1.67 GHz
  available frequency steps: 1.67 GHz, 1.33 GHz, 1000 MHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance
  current policy: frequency should be within 1000 MHz and 1.67 GHz.
                  The governor "performance" may decide which speed to use
                  within this range.
  current CPU frequency is 1.67 GHz.
 

1000 Mhz seems to be the stable frequency. Will check the other distros now,

Addendum:

Sabayon is running the same as Gentoo and Peppermint 2 is running around 55 to 65 percent of the time at 1000 Mhz and the rest at 1.67 Ghz, and has a kernel panic rarely. Now to try to set Arch like Gentoo if I can.

Addendum 2: Changed to governor to cpufreq_ondemand and it's now the same as Gentoo. Hopefully this solves the problem.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#46 2011-12-14 21:47:26

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Sabayon had a kernel panic but only one since the install. Gentoo zero and ArchBang is playing nicely now. There is still a problem with the cpu's syncing but the problem is minimal if the governor is set to ondemand keeping the frequency at 1000 Mhz most of the time.

@ Oliver I'm holding off on your suggestion for the moment to see how stable the current situation is. Later, I will try to decrease the number of cpu's working from 4 to 3 if cpu syncing kernel panics continue and see if that solves the problem. If it does, then I will modify my kernel to decrease the processors from 4 to 3 on a permanent basis.

Seems like marking this solved still has a way to go because the original problem in the post title line also has not gone away either with a kernel newer than 3.0.


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#47 2011-12-15 01:28:50

Mr Green
^! Developer
Registered: 2010-11-07
Posts: 5,178

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Does kernel26-lts work?

Offline

#48 2011-12-15 01:46:04

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

I'm trying the 2.6.39 when I get home today. I'll bet there's no problems with it. Udev has been a pain with usb staorage devices causing panics/crashes. Installed hal and those problems stopped. Funny how what seems to be deprecated and removed on Arch is still used on other distros and works fine (hal, aufs, hotplugging,etc.)


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

#49 2011-12-15 03:43:19

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,129
Website

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Installed hal and those problems stopped.
I thought so, that that would improve stability and solve some problems.
Lets not forget this to solve other problems.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#50 2012-01-07 06:52:56

ArchVortex
Retired AB Overlord
From: Junrejo, Jawa Timur, Indonesia
Registered: 2011-04-01
Posts: 1,456

Re: [Solved] [drm:intel_lvds_enable] *ERROR* timed out waiting for panel

Latest 3.2.0 kernel update fixes the original post problem. Finally roll


GUI's?? We don't need no stinkin' GUI's!!!
ArchBang-OpenRC / Slackware / Gentoo / FreeBSD / HaikuOS

Offline

Board footer

Powered by FluxBB