You are not logged in.

#1 2011-10-01 17:35:52

willxtreme
The Cook
From: Longueuil, Quebec, Canada
Registered: 2010-10-06
Posts: 275

ArchBang 2011.10 - Bug thread

Post bugs here smile

Offline

#2 2011-10-30 18:27:19

hsngrms
Member
From: Turkey
Registered: 2011-10-30
Posts: 70
Website

Re: ArchBang 2011.10 - Bug thread

External disks can not automounting (i use Thunar) after first update but solution is simple: reinstall "gvfs"

Maybe this is personal problem smile

I'm a bit newbie to Arch & English tongue

Offline

#3 2011-10-30 19:30:06

Keta
Member
From: Austria
Registered: 2011-09-13
Posts: 77

Re: ArchBang 2011.10 - Bug thread

i tested archbang 2011.10 few minutes ago, and i finished with install first bug come.
i install xf86-video-nouveau (Nvidia driver) there stand its a conflikt with xorg-server and y/N for delet i delet it and then a error come by reboot, anything with the X connected to fast or so.

Offline

#4 2011-10-30 20:22:14

hsngrms
Member
From: Turkey
Registered: 2011-10-30
Posts: 70
Website

Re: ArchBang 2011.10 - Bug thread

@Keta
Has nouveau already installed?
"As far as i remember" I installed restricted driver from nvidia.com, it want to uninstall nouveau and some other open source drivers.

Offline

#5 2011-10-30 22:50:08

Keta
Member
From: Austria
Registered: 2011-09-13
Posts: 77

Re: ArchBang 2011.10 - Bug thread

hsngrms wrote:

@Keta
Has nouveau already installed?
"As far as i remember" I installed restricted driver from nvidia.com, it want to uninstall nouveau and some other open source drivers.

no, grafik was 800x600 or so and i need 1920x1080 then i installed nouveau, then nothing go.^^

Offline

#6 2011-10-31 03:46:28

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,633
Website

Re: ArchBang 2011.10 - Bug thread

Search the wiki and the forums; this issue is very well documented
http://wiki.archbang.org/index.php?titl … org_Server


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

#7 2011-10-31 08:44:02

Kruppt
Moderator
From: Blue Ridge Mountains, NC
Registered: 2010-12-20
Posts: 299

Re: ArchBang 2011.10 - Bug thread

Keta wrote:

i tested archbang 2011.10 few minutes ago,
and i finished with install first bug come.
i install xf86-video-nouveau (Nvidia driver) there stand its a conflikt
with xorg-server and y/N for delet i delet it and then a error come by reboot,
anything with the X connected to fast or so.

If your trying to install the nouveau driver and related packages,
make sure you do not have the xorg/xf86 packages ignored in /etc/pacman.conf.
Look at "IgnorePkg   =" line in the pacman.conf and remove them from this line, as you need them.
If you had the nvidia 173xx drivers installed and wanted to continue using them you would have to be ignoring them (xorg packages)
because the latest X does not work with the current nvidia-173xx drivers and etc.
You would have to install the earlier version of X and related packages/depends.
Look in /var/log/packman.log to see which packages you upgraded that you should not have.
BUT if your trying to install nouveau you NEED the latest X packages.

If installing nouveau:
Cntrl-C to get back to prompt in the console you are dropped to, make sure you are root.
(The console you are dropped to when X doesn't start)
Open another console Cntrl-Alt-F2, (login as root, can't remember if you already are or not)
Make sure you have a network connection, if hardwired (NIC)

dhcpcd eth0 up

Cntrl-C anytime your are interupted along the way
by the X error message and start the latest command again,
you will be interupted every 5-10 min.(don't remember exactly)

pacman -Syu

Install packages (xorg etc.)

packer -S xf86-video-nouveau nouveau-firmware nouveau-dri mesa libgl

add "blacklist nvidia" to  /etc/modprobe.d/modprobe.conf
create /etc/X11/xorg.conf.d/20-nouveau.conf file;

sudo /bin/bash
touch /etc/X11/xorg.conf.d/20-nouveau.conf

add below to newly created 20-nouveau.conf file;

Section "Device"
    Identifier "Nvidia card"
    Driver "nouveau"
EndSection
nano /etc/X11/xorg.conf.d/20-nouveau.conf

Ctrl-o, then Ctrl-x when you have finished adding the above text to file.
rename /etc/X11/xorg.conf file;

mv /etc/X11/xorg.conf /etc/X11/xo

You can wait till X spawns again and if you did all rightly you will suddenly
be in your login manager (slim or whatever Will has setup now)
Or type

shutdown -r now

to reboot.
If you can't pull it off this way, you'll need to chroot from ArchBang LiveCd,
into your ArchBang install partition and do same as above or bootup via init 3.

Last edited by Kruppt (2011-11-01 15:53:24)

Offline

#8 2011-10-31 10:05:56

Mr Green
Administrator
Registered: 2010-11-07
Posts: 6,920

Re: ArchBang 2011.10 - Bug thread

Please add this to wiki it is useful for others, great post!


Comments, suggestions please feel free to contact me mrgreen(at)archbang(dot)org

Offline

#9 2011-10-31 14:00:07

pablokal
Administrator
From: Nijmegen, Holland
Registered: 2010-10-12
Posts: 3,633
Website

Re: ArchBang 2011.10 - Bug thread

Thanks, Kruppt for making more clear that you can also go for nouveau and how to do that.
So go with Kruppts solution if you want the open source nouveau driver.
Mine if you want  to keep the proprietary nividia driver which gives a better performance than nouveau.


Getting your questions answered here at ArchBang Forums
Please! Always give hardware info, if there is a chance that 's relevant: #lspci -vnn
On Arch(bang) and Openbox: http://stillstup.blogspot.com/

Offline

Board footer

Powered by FluxBB